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WYSIWYG Web Builder 
 

Introduction 
WYSIWYG Web Builder is an all-in-one software solution that can be used to create complete responsive 
web sites without coding. The acronym stands for "What You See Is What You Get," meaning users can 
visually design their pages, and the software generates the underlying code. It offers drag-and-drop 
functionality, customizable templates, and various tools for responsive design, animations, and form 
creation. Ideal for beginners and professionals alike, WYSIWYG Web Builder simplifies the web 
development process, allowing users to focus on design while the software handles the technical 
aspects. 
 
 
Key Features: 

• Drag & drop of HTML objects: Text, Lines, Images, Tables and much more! 

• Use Artificial Intelligence (OpenAI) to generate, improve or translate text and images. 

• Create a new unique website in just a few steps with the Website Wizard. 

• Responsive Web Design (breakpoints) based on CSS3 Media Queries. 

• Supports many CSS3 features: box-shadow, opacity, rounded corners etc. 

• Site Management. Easily add, edit, clone and structure your web pages. 

• Form wizard; create forms in less than 4 steps plus many Ready-to-use Forms! 

• Built-in form processing script with form validation tools and CAPTCHA. 

• Shape objects (Rectangle, Ellipse, Arrows, Signs, Stars, Talk Bubbles and more) with many fill 
effects such as solid, gradients patterns and glass. 

• Support for YouTube, Vimeo, JAVA, HTML5 Audio/Video, and other Plug-Ins. 

• Rollover images and Slide Show images (with many transition animations). 

• Rollover Text, displays a text banner over image on mouse over with animations. 

• Photo gallery object with photo frames and built-in light box slideshow support. 

• Ready-to-use Java scripts.  

• Navigation bar, Text Menu, Mega Menu, Tab Menu, Slide Menu, SiteTree and Menu bar. 

• Template support. More than 200 free templates available. 

• Publish your web site to any hosting. 

• Master objects and Master Frames. This allows you to re-use objects from other pages. 

• Layer Object for advanced layout possibilities: Modal, Sticky, Panel Fixed etc. 

• Free angle rotation for shapes and images 

• CSS3 animations and transitions. 

• Image tools: Contrast, Brightness, Flip, Rotate, Resample, Hue/saturation, Stencils and Crop. 

• Image effects: Grayscale, Negative, Sepia, Blur, Soften, Sharpen, Noise, Emboss and more!  

• Drawing tools: Line, Line + Arrows, Scribble, Polygon, Curve and Closed Curve. 

• Implement Events for Images, Shapes and form controls! 

• PHP Login Tools/Page Protection. 

• Content Management System functionality with plug-in support. 

• PayPal and other eCommerce Tools (Ecwid, Stripe, Snipcart, Paddle, Gumroad, WebMoney).  

• Site Search 

• Carousel functionality 

• News feed ticker object to integrate RSS feeds, Twitter, Flickr, Facebook etc. 

• and much more… 





WYSIWYG Web Builder 20   

8 

Start Web Builder 

Click the WYSIWYG Web Builder icon to launch the application. 
 
After launching WYSIWYG Web Builder, the main screen will look something like this: 
 

 
 
By default, the Ribbon interface will be active, but if you prefer you can also switch to classic 
menu/toolbars in Tools -> Options -> User Interface. 
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Quick Access toolbar 
You can put commands you use most often on the Quick Access Toolbar above the ribbon. Just like the 
Ribbon, this toolbar is fully customizable. 
 

 
 

File Menu 
The File Menu contains all file related commands like Open, Save, Close and Publish. 

 

 
 

Toolbox 
The toolbox can be used to add new objects to your web pages. To insert a new object, select one of the 
available items and draw a box to indicate the position of the object. The new object will now be 
inserted to the page. Another way to add objects to your page is by simply dragging them out of the 
toolbox onto the workspace. 
 

Tabs 
When you have opened multiple pages, you can use the tabs to switch between the pages. To close the 
active page, press the small 'x' in the upper right corner of the tabs strip. 
 

Workspace 
The center of the screen is the workspace, where you can drag and drop objects from the toolbox. This 
represents your web page. 
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Site Manager 
The Site Manager can be used to manage the structure of your web site. 
 

 
 
The Site Manager has its own toolbar to add, edit, clone or remove pages. There is also a button to open 
the properties of the selected page. For more information see also the “Site Manager” chapter later in 
this document. 
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Property Inspector 
Use the Property Inspector window to view and change the properties of selected objects.  You can also 
use the Property Inspector window to modify page properties. The changes will be visible immediately. 
The Property Inspector window displays different types of editing fields, depending on the needs of a 
particular property. These edit fields include edit boxes, drop-down lists, and links to custom editor 
dialog boxes. It is also possible to manually modify the size and position of the selected object by 
changing the Position and Size properties. 
 

 
 
The ID property 
The ID property of an object should be unique within the page. Normally Web Builder will give your 
object unique names automatically. However, if you use one of more master objects, then IDs may be 
duplicated, since the software cannot distinguish a master from a normal page. 
The Properties Inspector also gives you access to more advanced attributes like the ID of an object. This 
can be useful if you use master pages and want to give the items of the page a unique ID. We 
recommend giving objects on a master page names with a prefix like MasterPage_Text1. This will make 
sure that if the master page is used in another page, the ID of the objects is unique. 
 
Class 
Specifies the class name for the object. The value can be a style (created in the Style Manager) or a 
custom class. Some objects have a 'Predefined Style' option in the Style properties. This is basically the 
same property (Style = HTML class). However, for objects that do not support the predefined style, this 
property does not change the appearance in the workspace. In that case It just adds class="value" to the 
object's container. This may be useful for advanced users who want more control over the object's style 
or behavior.  
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Adding text to the page 
One of the first steps in creating a web page is often adding text. 
 

  
 
Select Insert -> Text from the menu and draw a box to indicate the position of the text. Then double 
click the box to start editing the text. Type some text and (press Enter to go to the next line). The box 
automatically changes its size to fit the text. 

 

 
 
Next, you can change the text attributes by highlighting the text you want to modify with the mouse and 
then choose the new attributes in the Format Tab. You can change font type, size, bold, italic, underline, 
text color, highlight color and many other attributes. Note that the formatting tools are also available in 
the context menu of the text editor. 
 

 
 
Click anywhere in the page to stop editing. 
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Adding an image to a web page 

Select Insert -> Image from the menu and draw a box to indicate the position of the image or select 
Image in the toolbox. The size of the box doesn’t matter; Web Builder automatically adjusts the box to 
fit the image after you place it. 
 

 
 
The Image File Open dialog appears so you can locate the image you want to place in the image box. 
Select the image you want to add and click Open to add it to the page. 
 
To resize the image, drag the borders (handles) of the image object. 
 

 
 

Rotate an image 
You can rotate image and shape objects. 
 
To rotate an object:  
1. Select the Rotate tool on the Ribbon or right click and select Rotate. 
2. Click to select the object, hover over one of its handles until you see the rotate pointer.  
3. Hold the mouse button down and drag in the direction in which you want to rotate the object, then 
release. Use the Shift key for 15° rotation intervals. 
 

 
 

Apply effects to an image 
In WYSIWYG Web Builder you can apply effects to images without having to open a separate image 
editor! A few of the available effects are Contrast, Brightness, Blur, Grayscale, Emboss, Negative, Sepia, 
Sharpen, Soften, Stencils and much more! 
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Linking your pages together 

Links are text or images that can be clicked to bring the user to another web file such as a web page, 
images or any other file. They are the essence of the World Wide Web as they link pages within sites 
and web sites to other web sites. To create a link in Web Builder, follow the instructions below. 
 

Linking text 
Highlight the text you want to link and select Insert -> Link from the menu bar, click the link button on 
the toolbar or press CTRL+K on your keyboard. This will display the Edit Link window. 
 

 
 
 

Linking an image and other objects 
Select the object you want to link and select Insert->Link from the menu bar, click the link button on the 
toolbar or press CTRL+K on your keyboard.  

 

 
 
 
Please read the chapter ‘Links’ of this document for more details about linking. 
 



WYSIWYG Web Builder 20   

16 

Saving your web site 

In WYSIWYG Web Builder you do not edit HTML pages directly. Instead, a project file is being used 
(.wbs) which stores all pages of your website within a single file. Every time you want to edit your 
website you open this project file. 
 
To save your web site (including all pages it contains), select File -> Save Web Site for the menu and 
enter a name for the project. Web Builder uses the extension .wbs (Web Builder Site) to save the project 
files, to save your page as HTML you'll need to Publish your pages. 
 

 
 
It is also possible to save the project as template, so it can be reused for other projects. 
 

 
Backup 
Project backup will create a full backup of the project, images and other files in zip format. 
The software also can automatically make backups, which is described later in this document. 
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Publish to a Secure FTP server 
The following protocols are supported:  

• FTP with TLS/SSL (Port 990 - Implicit)  

• FTP with TLS/SSL (AUTH TLS - Explicit)  

• SFTP using SSH2 (Secure Shell)  
 
The available settings are the same as for standard FTP. Note however that usually web hosts use 
different ports for secure servers.  
The default port numbers are:  

• Port 990 for FTP with TLS/SSL (Port 990 - Implicit)  

• Port 21 fort FTP with TLS/SSL (AUTH TLS - Explicit)  

• Port 22 fort SFTP using SSH2 (Secure Shell)  
  
Clear control channel  
Reverts the FTP control channel from SSL/TLS to an unencrypted channel. This may be required when 
using FTPS with AUTH TLS where the FTP client is behind a DSL or cable-modem router that performs 
NAT (network address translation).  
If the control channel is encrypted, the router is unable to translate the IP address sent in the PORT 
command for data transfers. By clearing the control channel, the data transfers will remain encrypted, 
but the FTP commands are passed unencrypted.   
 
Log Level  
Specifies the log level, which determines the amount of detail recorded in the logs during publishing.  
 

• Warning  
Only warnings and errors will be logged.  
 

• Info 
Only basic information will be logged, like which files are transferred. 
 

• All 
Detailed logging. This includes the transfer protocol commands.  

  
Be aware that logging can affect performance. The more information that is logged, the longer 
processing will take, potentially slowing down the transfer. 
 
 

Publish to a local folder 
If your web host doesn't support FTP or you want to use your favorite FTP client to transfer the files to 
the server, you can use the option 'Publish to a local folder'.  Click Add to add a new location to the list. 
Enter a name for the location a select ‘Local Folder’ as type. Enter the folder where you want to publish 
the active document. Click OK to save the data and then click Publish to save the files to the specified 
folder. Now you can take these files from the local folder and publish them using your preferred FTP 
utility. 
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Project backup in zip 
This will create a full backup of the project, images and other files in zip format. 
Note that the images and other files will only be included if they are stored in the project folder. 
Therefore, the option "Let WYSIWYG Web Builder manage images and other files used by a project' 
should be enabled. 
 
Preview in Browser 
Preview the active web page in your default Browser. 
Depending on the preview scope (Tools -> Options -> Misc), you can preview either a single page or the 
entire web site. It is also possible to change the browser that is used for previewing. Go to File -> 
Preview in Browser -> Edit Browser List to add/edit the list of browsers that can be used to preview the 
pages you are working on. 
 

Tip: You can also use the menu item 'Preview entire web site' to toggle between single page and entire 
website preview. 

 
 

Note: You cannot preview PHP pages directly in your browser. PHP can only be viewed via a web server 
with PHP support! 

 
 
Publish 
Publish the active page, a group of pages or the entire web site. You can choose to publish to a local 
folder or a remote FTP server. Check out the chapter ‘Publish’ of this document for more details. 
 
Site Summary 
The summary contains statistics about the web site project for informational purposes.  

• Created, the date the project was created. 

• Last Modified, the date the project was last modified 

• Total Editing Time, the total editing time in minutes (starting in version 18). 

• Project Size, the size of the project file (wbs) 

• Pages, the number of pages in the project 

• Images, the number of images in the project and total file size. 

• Video, the number of video files in the project and total file size. 

• Audio, the number of audio files in the project and total file size. 

• Downloads, the number of downloads (linked files) in the project and total file size. 

• Extensions, the number of extensions used in the project. 

• Fonts, the number of different fonts in the project. 
 
Exit 
Quits the application. 
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Home 

Paste 
Insert Clipboard contents. 
 
In text editing mode hold down the SHIFT key while using this command to paste without formatting. 
This can be useful when you are pasting text from MS Word which may include invalid control 
characters. 
 
Paste in Place 
Paste in Place is a method of pasting something in the workspace in the exact position that it was in 
when you copied it. 
 
Format painter 
Use the Format Painter to quickly copy formatting (color, font, border) from one object to another. Note 
that it does not work for individual text, only the container object. First select the object from which you 
want to copy the format. Then click the 'Format painter' button in the Ribbon and select another object. 
To apply the same formatting to multiple objects, you can double-click the 'Format painter' button and 
then select other objects.  To cancel the format-painter tool select the button again or click on an empty 
area in the workspace. 
 
Currently the following properties will be copied: 

• alignment 

• background color 

• background image 

• background texture 

• background mode 

• border color  

• border radius 

• border style 

• border width 

• box shadow 

• font size 

• font style 

• gradient color 

• gradient style 

• margin 

• opacity 

• padding 

• pattern style 

• text color 

 
Cut 
Cut the selection and put it on the Clipboard. 
 
Copy 
Copy the selection and put it on the Clipboard. 
 
Delete 
Erase the selection. 

 
Select All 
Select the entire document (all objects). 
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Undo 
Undo the last action. You can undo up to 255 actions. 
 
Redo 
Redo the previously undone action. 
 
Find 
You can search for words or characters on the active page or your entire website. On the Edit menu, 
click Find. In Find in, select Current Page or Entire Web Site. In Find what, type the characters or words 
you want to find, and then click Find Next. To find additional instances of the same text, continue to 
click Find Next. 
 

 
 
 
Replace 
You can search for and replace words or characters with text that you specify. 
On the Edit menu, click Replace. In Find in, select Current Page or Entire Web Site 
In Find what, type the characters or words you want to find.  
In Replace with, type the text you want to replace it with.  
Click Find Next, and then click Replace. To replace all instances of the text, click Replace All. 
 

 
 
 
Properties 
Edit properties of the selected object.  
 
HTML 
View generated HTML of the selected object or insert your own HTML code! 
Please note that this option is for advanced users only. Inserting invalid HTML code may cause 
unexpected results. 
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Don't Publish Assets (context menu only) 
If this option is enabled then Web Builder will not publish the assets (images, scripts, movies) for this 
object. For example, a media player will not publish the associated media file(s).  
This can be useful if a file already exists on the server, so it does not need to be published again. 
Note that it will still generate the HTML code for the object! 
 
Restore Original Size (context menu only) 
Can be used to restore an image or flash object to its original size. 
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View 
 
Full Screen mode: Normally, when you edit a webpage in WYSIWYG Web Builder, some of the screen is 
taken up with toolbars, a menu bar, a status bar, and other windows. To temporarily hide all this 
extraneous information to solely work on your page, click "View" and select "Full Screen Mode". 
Everything will disappear except your currently edited page. To go back, press the F11 key or click the 
Full Screen toolbar button. 
 
Refresh: The 'Refresh' option to reloads all images of the current page. This can be useful if you have 
edited images outside of Web Builder. 
 
Object Manager: Show or hide the Object Manager window.  
 
Properties Inspector: Show or hide the Properties Inspector window.  
 
Site Manager: Show or hide the Site Manager window.  
 
Toolbox: Show or hide the toolbox. 
 
Grid: Show or hide grid. 
 
Snap to grid:  Enable or disable snap to grid. Use the Snap to Grid feature to align objects exactly. Web 
Builder creates a "magnetic" attraction between the selected object and the grid.  
 
Snap to ruler guides: Enable or disable snap to ruler guides. 
 

Rulers: Show or hide rulers. 

 

Ruler Guides: Show or hide ruler guides. You can add ruler guides by clicking Ruler Guides -> Add 

Horizontal/Vertical user guide or simply drag a new guide from the ruler bar. 
 

Object Outlines: Show or hide object borders. 

 
Zoom 
You can zoom in to see parts of your web page close-up, or zoom out to see more of the page. You can 
either select one of the predefined zoom percentages or enter a custom value in the zoom toolbar. 
 

Notes: 
The quality of the zoomed page strongly depends on the zoom level. You will get the best quality for 
100%, 200%, 300%, 400% etc. But a zoom level of 150% will introduce rounding errors. 
You cannot edit text when a page is zoomed in or zoomed out. 
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Page 

 
New Page 
Adds a new page to your web site. The new page is automatically opened so you can start editing it right 
away. The new page (with a unique page name) with be added to the Site Manager tree. 
 
New Page from Template 
Create a new page based on a template. Pick any page from a template and insert it into the current 
project. The new page (with a unique page name) with be added to the Site Manager tree. Template 
functionality is described later in this document. 
 
Edit Page 
This will display a list of all the pages on your website. To open/edit the page, simple select the page 
name. 
 

 
 
Clone Page 
To make an exact copy of the active page, select Clone Page from the menu. A new item (with a unique 
name) will be added to the Site Manager. 
 

Note: 
'Clone Page' will duplicate the page and all objects on that page. To reduce the number of duplicated 
objects within your website you should consider using master pages. 

 
Delete Page 
Delete the active page from your web site. You cannot remove the last page in your web site. 
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Rename Page 
Rename the active page. Note that the Site Manager must be visible to be able to rename your page. 
The name of the page will be highlighted in the Site manager, where you can change its name. 
 

 
 
 

Note: When you have linked to the page you are renaming (from any page within the web site), Web 
Builder automatically updates all the links for you so you don't have to redo all the internal links. 

 
 
Notes about page names 
While building your web site, Web Builder saves the project file with the .wbs extension. This is a project 
file used by Web Builder to simplify the building process. One project file can contain multiple web 
pages. Once your pages are ready you must export or publish them as HTML.  
The name of the output HTML file is taken from the name you have specified in the Site Manager. 
So, if you named the page index then the output file will be called index.html. If the page needs another 
extension like .php, you can configure this in the Page Properties. 
 
Here are some guidelines how to name your web pages: 

1. Do not add .html or .htm extension to the page name. Web Builder will automatically add the 
.html extension (or .php, .asp) when it publishes (or exports) the HTML code. 

2. Always name your homepage: "index", this is the most common name for a homepage. 
3. Always use lowercase filenames, most web servers are case sensitive and might fail to find your 

page if you have called it "Index" or "INDEX" 
4. Use alpha numeric characters only. Do not use space or other special characters in the name, 

keep them simple like: 
"page1" or "my_products" 

5. Use underscores or dashes to connect words. 
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Import HTML Page 
Although Web Builder is NOT an HTML editor, you can import existing HTML pages. 
Select Page -> Import -> Import HTML Page from the menu to display the Import HTML page window. 
You can either select an HTML page from your local drive or specify a URL of an online website. 
Click OK to start importing the page. Web Builder will automatically copy all images to your local drive. 
 
Important notes about importing HTML: 

• WYSIWYG Web Builder is not an HTML editor, but an HTML generator! Web Builder imports the 
HTML by rendering the contents of an existing page and then attempts to convert the layout to 
Web Builder's internal object format. 

• The import feature currently only imports text, images, form elements and body attributes (link 
colors, background images, meta tags). Tables, scripts, style sheets and multimedia 
components are not imported. But in most cases, this is good enough to get you started. 

• Web Builder does not parse style sheets, so is some cases the text may look different than the 
original page.  

• Web Builder currently doesn't support framesets. If you want to import a web page that is 
using frames, you'll have to import all individual pages separately. 

• It is very difficult to support all different types of HTML. Even the popular browsers will 
interpret HTML differently, so don't expect miracles. If a page fails to be imported it probably 
contains code that Web Builder doesn't understand, and you still have to start from scratch. 

• Importing web pages created with WYSIWYG Web Builder will give the best results! 
 
Import page from another project 
This option makes it possible to import page from another WYSIWYG Web Builder project.  
 
Page HTML 
In this window, the HTML generated by Web Builder is displayed. To insert your own code, select the 
appropriate Tab. Select if the code should be inserted at the Start of Page, Between Head tag, Inside 
Body tag, Beginning of Body, End of body or End of page. The custom code will be displayed in blue. 
 
 

Warning:  
When you insert code in the Page HTML window, make sure you do not include the <HTML>, <HEAD> or 
<BODY> tags! WYSIWYG Web Builder already generates these tags. 
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• Start of Page 
The HTML will be inserted before all other code on the page. 
 
<-- your html --> 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" 

"https://www.w3.org/TR/html4/loose.dtd"> 

<html> 

<head> 

… 

 

• Between <head></head> tags 
The HTML will be inserted between the <head></head> tags. 
 
<head> 

... 

<-- your html --> 

</head> 

 

• Inside <body> tag 
The HTML will be inserted inside the <body> tags. 
 
<body attribute=value> 

 

• After <body> tag 
The HTML will be inserted after the <body> tags. 
 
<body> 

<-- your html --> 

 

... 

</body> 

 

• Before </body> 
 
<body> 

... 

 

<-- your html --> 

</body> 

 

• End of page 
 
<body> 

... 

</body> 

<-- your html --> 

 

• Inside <html> tag 
 
<html your html> 
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Page Properties 
Set or edit the properties of the active page.  
The property window of a page is subdivided into these categories: 
 

• General 

• Style 

• Meta Tags 

• Miscellaneous 

• Events 
 
 
Multi-Page Properties  
The Multi-Page Properties tool can be used to modify selected properties for multiple (selectable) pages 
at once. For example, to quickly change the master page for a group of pages. But also, background 
properties, meta tags, page extension etc. Only the modified value(s) will be applied to all selected 
pages, other values will not be affected. 
 
 
Site Properties 
Change the page properties of all pages within the current web site project. These values will also be 
used as the defaults for new pages. You can also launch the property categories individually (General, 
Formatting, Meta Tags, Internet Explorer and Misc). This can be useful if you only want to update the 
Formatting properties, without also affecting the meta tags and other categories for all pages. 
 

Note: 
Some properties like page size, title and extension are unique for each page, so these cannot be 
changed for all pages at the same time. To prevent you from accidental changing them and overwriting 
the properties of all pages, these properties have been disabled. 

 
 
Site HTML 
Insert (Page) HTML code that will be included on all pages. 
To include HTML code only for specific pages, use Page HTML. 
To include HTML code on multiple pages, but not on all pages you can use Master Frames.
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User defined variables 
This option can be useful to get global variables for the project, for example to quickly update the 
copyright or other value that regularly changes. 
The variables will be replaced during publishing by the specified value. You can use this variable 
anywhere in the page, text or property values. 
 
Example: 
Name: $COPYRIGHT$ 
Value: Pablo Software Solutions 
This will replace any instance of '$COPYRIGHT$' in the project by 'Pablo Software Solutions'. 
 
The following built-in variables are available (for advanced users): 
 
$PARALLAX_SPEED$ 
Specifies the speed at which the parallax effect runs. 0.0 means the image will appear fixed in place, and 
1.0 the image will flow at the same speed as the page content. The default is 0.3.  
 
$GOOGLEFONTS_PREFIX$  
This makes it possible to overwrite the 'http:' prefix used for Google web fonts. You can replace it with 
'https:' or leave the value empty. Default is 'http:' 
 
$VIMEO_PREFIX$  
This makes it possible to overwrite the 'http:' prefix used for the Vimeo URL. You can replace it with 
'https:' or leave the value empty. Default is 'http:' 
 
$PROJECT_CSS$ 
Normally, the name of the global style sheet is based on the project name (e.g. projectname.css).  
This system variable makes it possible to specify a different name. For example: globalstyles 
 
The following variable are set automatically: 
$PAGE_NAME$  
will be replaced by name of the page (without file extension). 
 
$PAGE_TITLE$  
will be replaced by the page title as specified in the page properties. 
 
$PAGE_FILENAME$ 
will be replaced by the filename of the page (with file extension). 
 
$FORMERROR_EMAIL$ 
Customize form error message. The default text is: The specified email address is invalid! 
 
$FORMERROR_FILESIZE$ 
Customize form error message. The default text is: The size of $key (file: $upload_SrcName[$i]) is bigger 
than the allowed \" . $max_filesize/1024 . \" Kbytes! 
 
$FORMERROR_URL$ 
Customize form error message. The default text is: URLs are not allowed! 
 
$CAPTCHA_ERROR$ site variable.  
This can be used to specify a custom captcha error message.  
The default text is: CAPTCHA verification failed. 
 



WYSIWYG Web Builder 20   

35 

$FORMERROR_HONEYPOT$ 
Customize form honeypot error message. The default text is: Spam detected. 
 
$SKROLLR_FORCEHEIGHT$ 
This option applies to scroll transitions: CSS3 Animations and Transitions 
Makes sure the document is high enough that all key frames fit inside. For example, you specified an 
offset of 1000, but the content only makes the document 500px high. skrollr will ensure that you can 
scroll down the whole 1000px 
Default is: 'false' 
 
$SKROLLR_MOBILECHECK$ 
This option applies to scroll transitions: CSS3 Animations and Transitions 
This option can be used to enable checks for mobile devices. Default is: false. which means that scrolling 
transitions are enabled on mobile devices. 
Important note: Some (older) mobile browsers do not provide 'real' scrolling events, but only trigger a 
start and finish event so any scrolling effect only takes place when the user has stopped moving the 
page so the animation would happen all at once at the end. 
 
$SKROLLR_SMOOTHSCROLLING$ 
This option applies to scroll transitions: CSS3 Animations and Transitions 
Smooth scrolling smoothens animations. When you scroll down 50 pixels, the animations will transition 
instead of jumping to the new position. Default is: 'false' 
 
 
Google Analytics 
Insert Google Analytics code in <head> section of the current page.  
This option is a shortcut to Page HTML. 
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Page Properties - General 
 
Title 
Enter the title of the web page. This title will be displayed in the title bar of the browser's window and 
search engine results. 
 
Menu Name 
This name will be used for the item names in navigation bars and menu bars which have enabled the 
option 'Synchronize with Site Manager'. By default, the page name (as specified in the Site Manager) 
and the button name are the same, but this field allows you to use an alternative name for the item. 
 
Page Width 
Specifies the workspace width of the page. 
 

Notes: 
1. This value is not used by the browser, it's only an internal value used by Web Builder to indicate 

the available workspace and to control the scrollbars when your screen size is not large enough 
to display the content of the page. 

2. The Center in browser option uses this value to calculate the absolute center of your page, so if 
you've designed your page for a resolution of 800x600, make sure this value is set to 800 or 
else your page will not be centered! 

 
Page Height 
Specifies the workspace height of the page. 
 

Note:  
This value is not used by the browser, it's only an internal value used by Web Builder to indicate the 
available workspace and to control the scrollbars when your screen size is not large enough to display 
the content of the page. 

 
Target screen size 
This option helps you determine the optimal page size for a specific screen resolution. It controls the 
page width/height properties. For example, if you select '800x600', then the page width/height will be 
set to 770x600, because you will have to leave some space for the vertical scrollbar, so you can't use the 
full 800 pixels for the page content. 
 
File extension 
Normally your web page will be published using the .html extension. In some cases, it might be 
necessary to specify another extension like .php of .asp in case your page uses PHP or ASP. 
 

Notes:  
If you set the file extension to something other than .html, then your browser may not be able to 
preview the page. To preview PHP or ASP page, you must publish the page to a web server which can 
handle these page types! 
 
After changing the file extension, you will need to re-publish all page’s link to it, otherwise the links will 
still refer to the old page name. 
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Don't Include this Page in the Site Map. 
When this option is enabled, the page will not be included in the site map. 
 
Character Set 
The character set tells the browser how to interpret and display the characters on your webpage. 
Depending on the language of the text on the page it might be necessary to force the browser to 
another character set. The most commonly used character sets are: ISO-8859-1 (ANSI) and UTF-8 
(UNICODE). 
  
Page Language 
Specifies the language (Content-Language) of the page. Search engines may use this tag to categorize 
pages by language. 
 
Direction 
Specifies the text direction for the content on the page. This can be either property set to 'left-to-right' 
or 'right-to-left'. 
 
 
Make Default 
Saves the current values as defaults for new pages.  
 

Note:  
You can also update the page properties for all pages at once using Page -> Site Properties! 
Or use multi-page properties to only edit specific properties for multiple pages. 
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Properties - Icons 
 
Favorites Icon 
You can use favorites icons (also known as shortcut icons or favicon) to display your logo or some other 
small graphic on the Favorites menu, address or page tabs of your browser. They are a great way to add 
brand recognition to your Web site. A shortcut icon must be square in size, and at least 16 x 16 pixels. 
Consider creating both a 16 x 16-pixel icon as well as a 32 x 32-pixel icon since on high-DPI displays, the 
browser may stretch the icon to fit the available space. To create the icon, use an icon editor, such as 
Axialis IconWorkshop, IcoFX or Microangelo Toolset and save the icon in the .ico file format.  
 
Optionally, you can specify dedicated image for 32 and 64 pixels in PNG format. 
 
 
Apple Touch Icon  
Like the Favorites Icon, the Apple Touch Icon is a file used for a web page icon on the Apple iPhone, iPod 
Touch, and iPad. When the user bookmarks the web page or adds the page to their home screen, this 
icon is used.  
Apple Touch Icons are also supported by most Android devices.  
 
Unfortunately, different devices require different image sizes. So, that is why we have now added the 
ability to configure multiple sizes. 
 
Common sizes: 
152x152 (iPad) 
167x167 (iPad Retina) 
180x180 (iPhone Retina) 
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Properties - Style 
 
Background mode 
Specifies the background mode. 
  

• Transparent 
The background of the page will be transparent. Note that normally this means that page will 
be white, because you cannot look through the browser window... 
 

•  Solid 
Use a solid background color. 
 

• Image 
Use an image as background. 
 
Repeat 
Sets the tiling attributes for the background image. Possible options are: 
- repeat in both directions 
- repeat in horizontal / vertical direction 
- do not repeat  
- space, the background-image is repeated as much as possible without clipping.  
- round, the background-image is repeated and squished or stretched to fill the space (no gaps). 
 
Horizontal Align 
Sets the horizontal position for the background image.  
 
Vertical Align 
Sets the vertical position for the background image.  
 
Background image size (this is the drop-down option at the right of 'repeat') 
Specifies the size of the background image. 
 
empty (default) 
The background-image has the default size and scrolls with the content. 
 
fixed 
A fixed background is a background image that will stay in one place while the rest of your text 
and images scroll over the top of it.  
 
cover  
Scale the background image to be as large as possible so that the background area is 
completely covered by the background image. Some parts of the background image may not be 
in view within the background positioning area. 
 
contain  
Scale the image to the largest size such that both its width and its height can fit inside the 
content area. 
 
parallax 
The image scrolls slower than the content in the foreground, creating the illusion of 3D depth.  
 
For advanced users: 
The default speed is 0.3. You can change this by adding a Site Variable with the name 
$PARALLAX_SPEED$ 
The speed at which the parallax effect runs. 0.0 means the image will appear fixed in place, and 
1.0 the image will flow at the same speed as the page content. 
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percentages 
For example: '100% 100%' will stretch the images to 100% of the object's width/height. Other 
values like '50% 50%' are also possible. 
 
pixels 
For example: '320px 250px' will display the image in the specified size. 
 

• Gradient 
Use a (two-color) gradient as background. 
The gradient can either be horizontal or vertical. By default, a background image will be 
generated for the gradient effect. However, you can also use CSS3 gradients by enabling the 
option 'Use CSS3 gradients instead of images' in Tools -> Options -> HTML.  
 

• Multi-color gradient 
Use a (multi-color) gradient as background. WYSIWYG Web Builder includes many predefined 
multi-color gradient styles, but you can easily create your own style with the Gradient 
Manager.  
 

• Pattern 
Use a pattern as background. A new image will automatically be generated for the pattern.  
 

• Texture 
Use a texture as background. A new image will automatically be generated for the texture. 

 
Background-clip 
The 'background-clip' property is an advanced option and it is available in Property Inspector and the 
Style Manager. It specifies the painting area of the background. This may be useful in combination with 
transparent borders.  'border-box' clips the background to the border box. When using a transparent 
border, the background will be visible behind the border. 'padding-box' clips the background to the 
padding box (excluding the border). The background behind the border will be transparent. 
 
Link Color 
This specifies the default, unvisited links color. 
 
Visited Link Color 
This specifies the color of a visited link. 
 
Active Link Color 
This specifies the color of an active link. 
 
Hover Link Color 
This specifies the color of all hover links of the active page. 
 
Underline mode 
Specifies whether links will always be underlined or only when the mouse is over the link. 
 

Note: You can also control the colors of links by using Link Style Sheets. For more information, see the 
description in the chapter ‘Links’. 

 
Default Font, Size and Color 
Specifies the default font, font size and text color that will be used for text you enter in the page. 
 
Theme 
Specifies the (ThemeRoller based) theme for the page. This theme will be applied to all theme enabled 
objects like jQuery UI widgets. Besides jQuery UI widgets you can also enable theming for the menubar, 
navigation bar, tab menu, slidemenu, horizontal line. This way you can give your page a uniform look 
and feel. Themes can be created and edited with the Theme Manager. 
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Properties - Advanced 
Overflow 
These properties specify whether content is clipped when it overflows the browser window.  
‘Overflow-x’ determines clipping at the left and right edges, ‘Overflow-y’ at the top and bottom edges.  
 

• none 
The overflow attribute will not be added to the page HTML. In this case scroll behavior may be 
different for each browser type.  

• visible 
This value indicates that content is not clipped, i.e., it may be rendered outside the browser 
window.   

• hidden 
This value indicates that the content is clipped, and that no scrolling mechanism should be 
provided to view the content outside the browser window.   

• scroll 
This value indicates that the content is clipped and that if the browser displays scrollbars.  
This avoids any problem with scrollbars appearing and disappearing in a dynamic environment 
where pages have different sizes.   

• auto 
The behavior of the ‘auto’ value is browser-dependent but should cause a scrolling mechanism 
to be provided for overflowing boxes.  

 
 
Layout Mode 

• CSS layout 
The recommended layout mode. This mode will use CSS (absolute positions) to create the best 
possible layout. All objects will be individually positioned, so you can overlap objects and place 
them anywhere you like. It also results in very clean HTML code.  

• Table Layout (not recommended!) 
This mode uses (invisible) tables to position objects on the page.  It does not allow objects to 
overlap! This technique was used by web designers before CSS was supported by all browsers. 
Note that today, all browsers do support CSS and table-based layouts are considered old 
fashioned technology. However, table layouts can be useful for Newsletters because email 
clients usually do not support CSS. See ‘Creating Newletters’ later in this document for more 
details. 
 

Use z-index for object order 
By default, all objects use the 'z-index' attribute to set the position in the z-order of the page. If for some 
reason, you do not want this, then you can disable this option. Do not change this value unless you 
know what you are doing! 
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Disable CSS media query 
When this option is enabled, then breakpoints/media queries will not be published. This may be useful 
for testing purposes. 
 
Disable HTML/CSS/JavaScript formatting 
This option disables beautify and minify options for the current page. This may be useful for testing 
purposes or when you have added code to the page which does not support formatting. 
 
Disable custom code 
When this option is enabled, then custom code with not be included in the published page. This makes it 
possible to test the page without custom code. For example, in case something does not work, you do 
not have to remove all code. 
 
Disable scroll events on small screens 
This option adds the ability to disable scroll events on small screens (e.g. phones).  
 
Disable scroll transitions on small screens 
This option adds the ability to disable scroll transitions on small screens (e.g. phones).  
'Minimum width' specifies the width at which the scroll events/ transitions will be disabled. 
 
Disable CSS animations and transitions on small screens 
This option will disable all CSS animations and transitions on small screens (e.g. phones).  
'Minimum width' specifies the width at which the scroll events/ transitions will be disabled. 
 
Note that this will only work for CSS animations / transitions. JavaScript animations will not be affected. 
 
Exclude browsers 
This option adds the ability to disable scroll events and transitions on specific browsers. 
Multiple browsers are separated by a pipe character. For example: 
Android|iPhone|iPad|iPod|BlackBerry 
 
Technical details: Exclude browsers uses the following JavaScript function to detect browsers: 
 
(/Android|iPhone|iPad|iPod|BlackBerry/i).test(navigator.userAgent || navigator.vendor); 
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Insert 
 
Most of the menu items are also available through the Toolbox. More details about the available objects 
can be found in WYSIWYG Web Builder objects later in this document. A few additional choices are 
available in the Insert Tab: 
 
Select 
The Select object is used to select objects. To select multiple objects, drag a selection box around them, 
or hold down the Shift key while you click them one at a time. 
 
Symbol 
Insert a symbol (special character) into a text object. This option is only enabled when you are in text 
edit mode. 
 

 
 
Link 
Opens a link dialog for the selected object or text. 
Check out chapter ‘Links’ for more details. 
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Format 

 
Most formatting tools apply to text only. WYSIWYG Web Builder allows you to make all the same 
attribute changes you can make in (for example) MS Word. To edit the formatting of text you must first 
double click the text object to go into edit mode, then highlight the text you want to modify with the 
mouse and select formatting option. 
 
Font Family 
Font type is the font family of text, such as Comic Sans, Times New Roman, and Courier New.  
To change the font type, select the font you want from the Font Type List Box on the toolbar.  
 
Font Style 
The style of the text can either be bold, italics, or underline.  
To change the font style, select one or more of the Style Icons on the toolbar. 
 
Font Color 
The color of the text can also be changed.  
To change the font color, select the Text Color Icon on the toolbar.  
The Color Dialog Box appears. Choose the color you want and click OK. 
 
Background Color 
To change the background color of the selected text, click the Background Color Icon on the toolbar.  
The Color Dialog Box appears. Choose the color you want and click OK. 
 
Change Case -> Sentence case 
Capitalizes the first letter of each sentence of the selected text. 
 
Change Case -> Lowercase 
Sets all selected text to lowercase. 
 
Change Case -> Uppercase 
Sets all selected text to uppercase. 
 
Change Case -> Capitalize Each Word 
Capitalizes the first letter of each word of the selected text. 
 
Change Case -> Toggle case 
Toggles the case of each letter of the selected text. 
 
Decrease indent 
Decrease the left margin (indent) of the current text line. 
 
Increase indent 
Increase the left margin (indent) of the current text line. 
 
Letter spacing 
Sets the amount of additional space between letters in the text. 
 
Line height 
Sets the distance between lines in the object. 
 
Font Size 
To change the font size, select one of the available HTML font sizes. 
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Text Alignment 
You can change the alignment of the selected text object by using one of the alignment buttons: Left, 
Center, Right or Justify. 
 
Remove formatting 
Sometimes it can be useful to remove all formatting from a piece of text at once. Highlight the text and 
select Remove Formatting to reset all styles to its default values. Formatting removed from the text 
include bold, italic, underline, subscript, superscript, strikeout, text color and background color. 
 
Remove link 
Removes the link that was assigned to the selected text. 
 
Search in Google 
When you are editing text, this command will search the selected word on Google. Your computer must 
be connected to the Internet.  
 
Look Up in Dictionary 
When you are editing text, this command will look up the selected word on the website: 
https://dictionary.reference.com/  
Your computer must be connected to the Internet. 
 
Styles 
In the Style Manager you can manage the styles of a project. By using styles, you can modify the style of 
the entire website all in one place. 
 

General Styles 
In the General Style page HTML/CSS styles can be defined, such as text header styles (H1, H2, 
H3 ...) or form element styles. See also: Style Manager. 

 
Link Styles 
By default all links in your webpage use the default HTML link colors as defined in the Page 
Properties. But by using link styles you can set the style of individual links. 
a) Create a new style 
b) In the (text) link properties select the style. The style will be applied when you preview or 

publish the page. 
 

Gradient Styles 
Use the Gradient Style Manager to add/edit and remove global (multi-color) gradients effects. 
Gradient effect can be used by Shapes, ClipArt, TextArt and other drawing tools. 
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Table 
The Table Menu contains all the operations related to creating and modifying tables. Tables have 
columns and rows of cells that can contain text (images, forms, or other page elements are not 
supported now). Tables are useful for the layout of data; they can be used to simulate columns of text. 
When you type text in a table cell it expands horizontally and vertically to accommodate the text that is 
typed or inserted. You can edit, format, and specify properties (background color or image) for the text, 
as well as for the table cell, row, column, or table itself. You can easily resize cells, columns, rows, or the 
entire table by dragging the borders.  
 
Insert Table 
Draw a box where you want to position the table. 
The Insert Table dialog appears. 
Enter the number of cells and rows required.  
Enter layout and size details and click on OK  
   
Insert Rows or Columns 
Select this option if you need to insert additional rows and columns after a table has been created. 
Specify if you want to insert Rows of Columns and enter the number of rows/columns to be added. 
To insert a column to the left of a selected column, choose Left of selection. 
To insert a column to the right of a selected column, choose Right of selection. 
To insert a row above a selected row, choose Above Selection. 
To insert a row below a selected row, choose Below Selection. 
 
Merge Cells 
Merge two or more adjacent cells. This command is only available when two or more adjacent cells are 
selected on the same row. 
 
Split Cell 
Split the selected cell into columns. 
 
Delete Column 
Select this option to delete the selected column. 
 
Delete Row 
Select this option to delete the selected row. 
 
Table Column Width 
Set the column width for the selected column. 
 
Table Row Height 
Set the row height for the selected row. 
 
Sort 
Sort text (Ascending/Descending) of a table column or row. 
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Table Properties 
 
Border Size 
Enter how wide you want the border to be, in pixels. 
 
Cell Padding 
Enter how much space you want between the contents and inside edges of cells, in pixels.  
 
Cell Spacing 
Enter how much space you want between the cells in the table, in pixels. 
 
Background color 
Specifies the color of the form background. If set to 'Automatic' the webpage background will be used. 
 
Background image 
Specifies the optional background image. 
 
Border color 
Specifies the color of the table's borders. If set to 'Automatic' the table will have a 3d border. 
 
Hover rows color 
Enable a hover state on table rows. 
 
Striped row color 
Add zebra-striping to the table rows. 
 
Header row 
This will output the first row as header cells (<th> instead or <td>). 
 
Size mode 

• Pixels, the size of table cells is in pixels. This will get the best 'pixel perfect’ result. However, 
when using the table in responsive layouts, it cannot be resized in breakpoints. 

• Percentages, the size of cells is in percentages. The cell sizes will be approximately based on the 
design time dimensions. Using this option makes it possible to resize the table in breakpoints. 
However, the cell sizes will still have the same percentages relative to the table size. 

• Automatic, when using this mode, the table cells will be automatically sized based on their 
content. This makes it possible to use a table in layout grid layouts. 

 
Table Styles gallery  
The 'Table Styles' gallery (in the Ribbon). This allows you to quickly update the style of your tables. You 
may know this feature from MS Office. 30 predefined styles are currently available. 
 
Sort 
Sort text (Ascending/Descending) of a table column or row. If you sort a column, then the other columns 
will be moved too. Also, the style of the cells will be included, not only the text, so cells keep their own 
styling.  
 
Import data from text file 
A quick way to get data from a comma separated text file into the table. Data should be separated with 
a comma. 
 
Table HTML 
View generated HTML of the table. You can also insert your own HTML code! 
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Arrange 

The arrange menu contains all operations related to the layout of the current page. 
 
Align 
Lefts 
Align the left edges of the selected objects with the dominant object. 
  
Centers 
Align the centers of the selected objects with the dominant object. 
 
Rights 
Align the right edges of the selected objects with the dominant object.  
 
Tops 
Align the top edges of the selected objects with the dominant object.  
 
Middles 
Align the middles of the selected objects with the dominant object.  
 
Bottoms 
Align the bottom edges of the selected objects with the dominant object.  
 
Space Evenly 
Across  
Evenly spaces the selected controls horizontally. 
 
Down 
Evenly spaces the selected controls vertically. 
  
Center in Page 
Vertical / Horizontal 
Centers the controls vertically or horizontally within the web page.  
 
Make same size 
Width 
Resize the selected objects to have the same width as the dominant object. 
 
Height 
Resize the selected objects to have the same height as the dominant object. 
 
Both 
Resize the selected objects to have the same size as the dominant object. 
 
Arrange 
Move to Front         
Move object to front of the page. 
 
Move to Back 
Move object to back of the page. 
 
Move Forward 
Move object to next position in z-order. 
 
Move Back         
Move object to previous position in z-order. 
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 Group 
You can group multiple objects, so that they stick together when you move them. When you select one 
object from a group, the other objects will automatically be selected too. Grouped objects cannot be 
edited until you ungroup them. 
 
Ungroup 
Ungroup objects. 
 
Merging Objects 
By using this option, you can merge multiple objects into a single image! This can be useful for merging 
multiple (layered) shapes into a single image to reduce the number of published images and speed up 
loading times. This option will basically convert any object (or group of objects) into an image. So if this 
is used for objects like forms, buttons, menus then they will lose their original functionality, since they 
will be published as a static image. 
 

Tip:  
You can also use this option on a single object. This can be useful to convert an image or shape to 
another image format. 
 
For example, let's say you have applied a shadow effect to an image. The output format of the image 
will then be PNG. Now select 'Merge' from the menu. The image will be converted to an 'merged 
object', you can now select another output format like jpg which will result in a smaller output image). 
Q: But wait.... what will happen to the transparency of the shadow?  
A: The merged object will make a 'snapshot' of the background objects and use that as background 
image! 

 
 
Merge Objects 
Merge the currently selected objects. In the properties of this object, you can specify the output format 
of the image. 
 
Split Objects 
This option will split previous merged objects. 
 
Save as Block 
Save the selected object(s) as Block, so you can reuse them later in the same (or another) project. 
Blocks are ‘building blocks’ that make it possible to quickly create a website by dragging predefined 
blocks to the workspace. Blocks Once the block has been dragged to the page you can fully customize 
the behavior and appearance of the content. 
 
Rotate 
This command will activate the rotate mode. You can rotate images and shape objects. 
For more information see also: Rotation 
 
Lock/Unlock 
This will 'lock' the selected objects, so that they cannot be moved or resized accidentally. Note that this 
will also prevent you from editing the objects’ properties unless you enable the option 'Allow locked 
objects to be edited' in the Tools -> Options -> Advanced configuration. To unlock the object again, 
repeat the same command. 
 
Lock All 
This will lock all objects in the active page. 
 
Unlock All 
This will unlock all objects in the active page. 
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Guide settings 
 
Snap to ruler guides 
Enable or disable snap to ruler guides  
 
Show Table Cell Outlines (if border = 0) 
When this option is enabled, Web Builder will draw table cell outlines even if the border is zero. 
 
Show Guide Borders 
Guide borders can be useful when designing a web page for specific resolutions. If you make sure all 
objects stay between the guide border, the final page will fit in the desired window size. 
 
Show smart guides when objects are aligned 
Smart guides are dynamic guidelines that appear when you move objects into alignment with each 
other. 
 
Lock page size (no automatic page adjustment) 
Normally Web Builder will automatically update the page size if you place an object outside the page 
borders. When this option is enabled, the page width will be locked even if you place objects outside the 
border.  If you want a larger workspace you will need to update the page width/height manually in that 
case (using Page Properties). 
 
Show Grid 
Show or hide grid. 
 
Snap to grid 
Enable or disable snap to grid. Use the Snap to Grid feature to align objects exactly. Web Builder creates 
a "magnetic" attraction between the selected object and the grid.  
 
Grid Spacing 
Specifies the spacing between the grid dots. 
 
Show Tooltips while resizing and moving objects and guides 
Enable this option if you want to see the current position (while moving) or size (while resizing) of the 
current object in a tool tip above the mouse cursor. 
It also works while moving ruler guides! 
 

Note:  
This option may cause objects to render a little bit slower during moving/resizing because the tooltip 
needs to be updated constantly. 

 
 
Edit Points 
This option can be used for Polygons and Curves to add, edit and remove nodes. 
To start editing nodes, first select Polygon or Curve and then select 'Edit Points' from the menu. 
To edit existing nodes simply hold the left mouse button and drag it to its new position. 
To add a new node, click anywhere on the line and drag the point to the desired position. 
To remove a node, hold down the CTRL key and click the node with the left mouse button. 
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Ruler guides 
Horizontal and vertical ruler guides are used to align objects on the page.  
Typically, ruler guides are placed on the page by dragging them from the horizontal and vertical rulers or 
by specifying precise positions using the 'Format Ruler Guides' dialog box.  
Alternatively, you can use the menu option 'Add Horizontal Ruler Guide' or 'Add Vertical Ruler Guide' to 
insert a new guide. 
  
To move the ruler guide, position the mouse pointer over the guide, until you see the vertical or 
horizontal Adjust pointer and then drag the guide to its new position.  
 
You can remove a single ruler guide or all ruler guides from a page. Position the mouse pointer over the 
ruler guide you want to delete until you see the adjust pointer and then drag it back to the ruler. Or you 
can use the 'Format ruler guide' dialog box to delete the ruler. 
 
To remove all ruler guides in a page, select the Arrange menu, point to Ruler Guides, and then click Clear 
All Ruler Guides.  
 
Objects which are placed close to a guide "snap to" the guide for easy alignment. 
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Tools 

 
Asset Manager 
The Asset Manager can be useful to modify the location of one or more assets (images, movies, sounds 
etc.) without the need to open the properties of each item. You can select which group of items will be 
displayed in the Asset Manager (Filter). 
 
To change the location of only 1 asset, simply select the item, click the 'Update' button and select the 
new location. To change the location of multiple assets, select the items, click the 'Update' button and 
select the new location. This means that you can update the location of all assets with just a few clicks! 
 
It is also possible to move assets to another location. In that case a copy of the assets will be made to 
the specified location and update the path in the editor. Note that the original file will not be deleted! 
 
Another useful feature of the Asset Manager is the ability to show all orphan files in the project folder.  
Select Filter -> Orphan files to display a list of all the assets no longer used by the current project. Now 
you can select and remove those files from the project folder. 
 
Linked files, displays a list of the downloads in the project. 
Extensions, displays a list of all the extensions used in the project. 
Copy, Copy the file list to the clipboard. 
 

Backup Manager 
Each time you save your project the software will automatically create a backup of the previous version 
of the project. The backup behavior can be configured in Tools -> Options -> Backup 
 
The Backup Manager can be used to easily restore and delete automatically created backups. The 
Backup Manager will display the time and date of the backup and the filename. The back upped files will 
have file names like: myproject_01.wbs, myproject_02.wbs, myproject_03.wbs. The highest numbered 
file will always be the latest backup.  
 
To restore a backup, select the filename and click 'Restore'. The file will then be moved back to the 
project folder and renamed to its original name. 
 

Notes:  
- The Backup Manager will override the current version of the project! 
- A backup cannot be restored if the project is currently in use. So close the project before using the 
Back Manager. 

 
 



WYSIWYG Web Builder 20   

63 

Page Weight 
The Page weight tool helps you determine the estimated size and download time of a page. 
The tool will list all files which are part of page and their sizes. By selecting the connection speed, you 
can get an idea how long it will take to download the complete page. Note that some files (like scripts, 
images) are used by multiple pages. They will be downloaded only once by the browser. 
 
 

Link Manager 
This option scans your documents for links and displays them in a list. 
You can choose to edit them or press the Verify button to validate their current state. 
 
Possible states: 
Not verified  - not verified yet 
Validated URL  - URL is valid 
URL not found  - URL is not valid (or currently not reachable) 
 
This tool can be handy when you want to verify all your links, so you don't have to verify them one by 
one. 
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General Options 
Create blank document at startup 
Enable this option to create a new empty project when the application starts up. 
 
Application window maximized at startup. 
Enable this option to maximize the application window at startup. 
 
Open the most recent used file at startup 
Specifies whether to open the most recent used project at startup 
 
Open the most recent used page of the project 
This will open the page that was active when you last saved the project. 
 
Show splash screen 
Enable this option to display the splash screen/copyrights image at startup. 
 
Allow locked objects to be edited. 
Locked objects cannot be moved or resized, but you can still edit their properties. 
 
Check for updates online at startup. 
This option will connect to the Web Builder website to check if there is a new version of the software 
available. 
You can also check for updates in the Help menu: Menu -> Help -> Check for updates online. 
 
Show page extensions in Site Manager. 
Enable this option to display the extension of the page (html, php, asp etc.) in the Site Manager. 
 

Note:  
You must restart the application before the page extensions will be displayed. 

 
Automatically check for duplicated IDs when page is loaded. 
Enable this option to automatically check for duplicated IDs when page is loaded, published or 
previewed.  If the software finds duplicated IDs, then it will show a message with a link to Error Reports. 
 
Use ctrl+click+drag to duplicate objects 
Enable/disable ctrl+click+drag (duplicate objects) functionality. 
 
Text Box 
Initial Text: Specifies the initial text of a text object. Default: Double click to edit 
 
Do not show initial text, but directly go into edit mode when created. 
If you enable this option, then the initial text (Double click to edit) will not be displayed. You can directly 
start typing text into the box. 
 
Synchronize MySQL settings between login objects 
When this option is enabled, any updates made to MySQL properties will automatically apply to all login 
objects. Additionally, new login objects created in the project will inherit the same settings as existing 
objects. This eliminates the need to configure each object individually, streamlining the process and 
ensuring consistent settings across all login objects. 
 
Enable 'Use Theme' as default for new objects 
Specifies whether to enable theme support for all newly created objects. 





WYSIWYG Web Builder 20   

70 

HTML Options 
Generate external CSS style sheets for page specific styles. 
Enable this option to generate a separate CSS file with the styles used by a page. The name of the file 
will be the same as the page name. So 'index.html' will generate an ‘index.css' file. 
Inline styles will not be part of the style sheet! So, for the best results your objects should make use of 
styles created in the Style Manager. 
 
Generate single CSS style sheet for global styles. 
Enable this option to generate a single CSS file with all styles created in the Site Manager. All pages will 
refer to this file. 
The global style sheet will not contain page specific styles (like menu bar styles). 
 
Optimize inline styles (experimental) 
This is an option which attempts to clean up the HTML code by moving inline styles to the page's style 
sheet.  
 

Note:  
This option will process all HTML elements on the page, however not all (third party) extensions may 
support this behavior.  So please test all functionality of your website before using this! 

 
Web Fonts (@font-face) 

• Do not use @font-face (default) 
No code will be generated to support non-web safe fonts. 
 

• Automatically use @font-face for non-websafe fonts. 
If you enable this option, you will be able to use any type of true type font even if it's not web 
safe by using a new CSS3 feature called @font-face. WYSIWYG Web Builder will automatically 
generate the necessary code and upload the font to the server. It will even generate a 
secondary (eot) font file required to make this feature work with IE! 
 

• Manually specify @font-face fonts. 
In some cases it's necessary to manually configure @font-face. For example, if it's not possible; 
to automatically determine the filename associated with a specific font or if you want to use 
separate files for each format. Enabling this option allows advanced users to manually link font 
files to a specific font. 

 
 

Use CSS3 gradients instead of images (when possible). 
Enable this option to generate CSS styles for background gradients instead of images. This reduces the 
number of images generated for the page. Keep in mind however that not all browsers (especially 
Internet Explorer!) do support CSS3 gradient yet. Also note that not all gradient styles are yet supported, 
for in some case images still will be used. 
 
Publish navigation icons as SVG image.  
This will output the icons as embedded SVG (scalable vector image) instead as font and reduces the 
overall size of the website if you only use a few icons. 
This option applies to icons used in: Breadcrumbs, Cards, Mega Menu, Overlay Menu, Panel Menu, 
Responsive Menu, Tabs, Themeable Menu and Toasts. 
 
Dark Color Scheme 
Normally, the dark color scheme is activated by the browser based on the user's preference (prefers-
color-scheme). In that case, dark colors will automatically be used.  
But it is also possible to switch between dark / light mode manually via events. For more details, see this 
online tutorial: https://wysiwygwebbuilder.com/darkcolorscheme.html 
 



WYSIWYG Web Builder 20   

71 

Include page name in automatically generated ID attributes. 
This option will add the page name to automatically generated ID when a new object is added to the 
page. So for example 'Image1' it will become 'indexImage1'. Where 'index' is the name of the page. 
This can be useful when you use lots of master pages in which case it will prevent duplicated ID 
attributes within a page. 
 

Note:   
This option does not change your existing ID's only for newly created objects! 

 
Enable HTML encoding (based on the selected character set). 
This will save the document encoded with the selected codepage. This is a new feature in version 7.5 in 
an attempt to generate (even) better W3C compliant HTML documents. This option should be enabled 
unless you are experiencing problems with character display in browsers. 
 
Enable URL encoding to prevent web unsafe file names. 
Specifies whether to use URL encoding for file names. In general, you should not use white spaces or 
other non-alphanumeric characters in file names, because it may confuse web servers and browsers 
(especially in combination with JavaScript). If you enable this option, then the software will encode file 
names to prevent possible problems with invalid file names. Of course, it's still better to make sure your 
filenames are valid before adding them to your website. 
 
Use shared folder for assets (pages in folders will not have their own asset folder) 
Enabling this option will share the asset target folder(s) for the entire website (including pages in sub 
folders!). This means that sub folders in the Site Manager no longer use a separate asset folder. 
Note that you can set the target folder for specific file types in Publish & Preview. If this option is 
disabled, then each folder you create in the Site Manager will have its own asset folder. 
 
Use HTML5 Semantic Tags 
When this option is enabled the application will automatically output semantic HTML5 tags instead of 
divs. For example, page header <header> page footer <footer>, navigation <nav>,. 
 
Enable Cache Busting for external CSS and JS files 
To speed up load times, Web browsers are designed to cache CSS and JS files. The cached files are 
stored on the visitor’s computer, so the next time they visit a site, these files will be loaded faster.  
However, this may cause issues if you have made changes to the website, but the browser still loads the 
previous (cached) version of the files. When cache busting is enabled, unique suffixes will be added to 
the file paths of the CSS and JS files. This forces the browser to re-load the files from the server. 
 
Note that this only applies to dynamically generated CSS and JS files: global style sheet (eg. project.css), 
page specific CSS file (eg. page.css) and page specific JS file (eg. page.js). 
If you want to disable caching of HTML files, then this either needs to do in the server configuration or 
via Meta tags. 
 
Include width and height attributes in images to prevent Cumulative Layout Shifts 
Specifies whether to include width and height attributes (width="800" height="600") in <img> tags in 
addition to CSS. This helps the browser to allocate the correct amount of space in the document while 
the image is loading. 
This may be useful to improve Google's lighthouse 'Best Practice' scores.  
 
Include structured data in navigation objects for improved SEO ranking 
Specifies whether to include structure data (https://schema.org/SiteNavigationElement) in navigation 
items. This may help search engines to better understand the structure of the menus on the page. 
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Files & Folders Options 
In the System Folder option, you can configure where the software will store all user specific data, like 
extensions, templates, publish settings, gradients etc. 
 

Important: 
If you change the System Folder then this will also change the location where WYSIWYG Web Builder 
looks for extensions, templates, publish setting etc. So, if you change the folder then make sure you also 
move all files to the new folder! 

 
If you enable Let WYSIWYG Web Builder manage images and other files used by a project, then Web 
Builder will make a backup copy of all assets (images, movies, sounds) which are part of your website to 
a folder relative to the project file, so all files will be stored in one place. The name of the folder will be 
the same as the project name. This means that if your project is called 'mywebsite', then all assets will 
be stored in the sub folder 'mywebsite'. Copying or moving your project to another computer is now as 
easy as copying the project file and its sub folder to another PC! 
 
In the Preview Folder field you can change the default folder which is used for the preview files. This can 
be useful if you want the files to be copied to a folder of your local web server in case you generate PHP 
or ASP pages. 
 
If the option Remove preview files is enabled, Web Builder will remove all previously generated files the 
next time you select the preview option. This prevents old files will be left behind and only new files 
exists in the preview folder.  
 

Warning: This will remove all files from the specified folder! (not only the files that were previously 
generated by Web Builder). 

 

Publish & Preview Options 
Connection Timeout, increase this value if you experience timeouts while connecting to the FTP server. 
Default is 30 seconds. 
 
Enable Logging, enable logging when you have problems while publishing your web site. The log might 
contain useful information about the problem. 
 
Images name prefix. Some objects such as shapes, navigation bar buttons will be published as 
(dynamically generated) images. These images do have a unique name within the website (e.g. 
img0001.gif, img0002.gif). With this option you can control how the images will be named. For example, 
if you specify wbimage as prefix, the images will be named 'wbimage0001.gif' or 'wbimage0002.png' 
It is also possible to make the name of the page part of the filename by enabling the option Use page 
name for image prefix, this makes it easier to keep track of which images belong to a specific page 
 
Target folder for File Types 
WYSIWYG Web Builder can publish the images, scripts, swf, pdf, css and other files it generates to a 
separate folder on the web server. This will keep your web site organized. 
If the web server does not support sub folders, then remove all file types from the list. In that case all 
files will be published to the same folder as the HTML files. 
 

Note: The folders are relative to the folder of the HTML page. So, if you have created folders in the Site 
Manager then each folder will have its own sub folders for the files! 

 
Preview Scope, this option specifies the preview scope of Web Builder. Select Current Page to only 
preview one page or Entire Web Site if you want to test your complete web site. 
 

Tip:  
Holding down the SHIFT key while previewing will 'invert' the current preview scope. 
This means that if 'Current Page' is selected then holding de SHIFT key will preview the Entire Website'. 
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Remove PHP code during preview 
Many of the advanced features of WYSIWYG Web Builder use PHP code. As you may know, browsers 
cannot interpret PHP code and usually will display errors or nothing at all! Previewing the layout of such 
a webpage on a server is not always convenient, so that's why we introduced this option. If this option is 
enabled then all PHP code will be removed during preview, so you can view the layout. Of course, you 
will still be to publish the page to a PHP enabled web server to fully test the (dynamic) behavior of the 
page. 
 

Note:  
During preview the software will rename the page's file extension from .php to .html.  
This means that if other pages link to this page, then the browser will not find the page since it has a 
different extension. 

 
Hide file extension for internal links (for advanced users only!) 
Remove the extension from internal links. Instead of 'page1.html', the application will use 'page1' in 
navigation objects and links. 
 
Note that the generated files will still have extensions otherwise they will not be recognized as 
HTML/PHP files on the server! You will need to configure the server to hide the extensions on the server 
via .htaccess. 
 
For example: 
 
PHP EXTENTION REMOVAL 

RewriteEngine On 

RewriteCond %{REQUEST_FILENAME} !-f 

RewriteRule ^([^\.]+)$ $1.php [NC,L] 

 

HTML EXTENTION REMOVAL 

RewriteEngine On 

RewriteCond %{REQUEST_FILENAME} !-f 

RewriteRule ^([^\.]+)$ $1.html [NC,L] 
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User Interface 
Language: Use this option to specify the language used for the user interface. Default is English. Before a 
certain language is available from the dropdown list, you need to install the appropriate language 
module. Visit the website of WYSIWYG Web Builder to check for the available languages. 
 
User Interface 
Specifies whether to use the classic menu and toolbars or the Ribbon interface. 
 
Docking algorithm for resizable bars: Default or Visual Studio 2005 style. When Visual Studio 2005 style 
is selected, so called Dock Markers are displayed when you reposition windows like the Site Manager or 
Toolbox. 
 
Display web safe fonts only 
You can enable this option so WYSIWYG Web Builder will only display web safe fonts.  
 
Display rotate handle for rotatable objects 
Specifies whether to display rotate handles in the workspace to provide quicker way to rotate objects.  
 
Color picker 
By default, the color picker displays a standard color palette with 140 standard web colors. With the 
'Swatch colors' option (inspired by the MS Office color picker) you can configure a custom color palette 
of 12 colors. The light and dark variants of these colors will be generated automatically. 
 
Color box shape 
Defines the shape of the color swatches in the color picker. You can choose between square or ellipse. 
 
Enable live HTML rendering of extensions. 
Some extensions use 'live HTML rendering' which means they create a live preview of the generated 
HTML code for the extension. And although this may be useful to get an idea what the final page will 
look like, it also can use lots of system resources (memory /processor time), especially when you are 
using many extensions in the same project. Disabling this option can reduce the memory usage and 
loading time of projects. It will have no effect on the generated output. 
 
Tab 'Close' button 
Specifies the appearance and behavior of the close button on the page tabs. 

• None 
No close button on the tabs. 

• Active Tab 
Close button is displayed on the active tab only. 

• Highlighted Tab (Compact) 
Close button is displayed on the active and highlighted tabs.  The space for the close button on 
the non-active tab is not reserved. 

• Highlighted Tab 
Close button is displayed on the active and highlighted tabs. 

• All 
Closed button is displayed on all tabs. 
 

New Page Label 
The 'New Page' tab is a quick way to add new pages.  
By default, the new page tab only contains the ‘+’ sign, but you can change the text of the tab in Tools -> 
Options -> User Interface. If you leave the field empty, then the new page tab will be hidden 
 
Automatically Hide Scrollbars 
When a scrollbar is inactive (the mouse cursor is not located inside it), only compact (thin) thumb box 
will be drawn. When you move the mouse inside the scrollbar, the bar will be fully drawn. 
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Backup 
Backup folder: WYSIWYG Web Builder can automatically make backups of your projects, before 
overwriting a previous version of the project. 
Backup folder specifies the folder where the backup will be stored.  
 
Total number of site backups. Specifies the number of backups to keep before overwriting them with 
newer versions. Enter 0 if you do not want Web Builder to create backups. 
Web Builder will name the backups like this: 
myproject_01.wbs,  myproject_02.wbs, myproject_03.wbs 
The highest numbered file will always be the latest backup. If the maximum number of backups is 
reached, the oldest backup will be deleted, and all other backups will be renamed. 
 
Auto backup 
Enable this option to automatically make backup copy of your project every 5, 15, or 30 minutes. This 
may help you restore your work if your computer crashes unexpectedly. 
The name of the backup will be myproject_autobackup.wbs and it will be stored in the backup folder. 
 
Make a backup of the project on the server. 
Enable this option to automatically make a backup of the project on the server. This may be useful if 
your computer crashes or your local projects become corrupted. In that case you will always have a 
backup copy on the server. 
 
AutoSave 
This automatically saves the active project at the specified interval. 
Note that this does not work for new 'untitled' projects, because the project must have a filename 
before it can be saved. 
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Search Index 
WYSIWYG Web Builder has basic built-in 'search engine' functionality, so visitors can search for specific 
words within your website.  
To make this feature available to non-advanced users we decided to use JavaScript as it does not require 
you to setup database and indexing service on the server. The downside is that it can be slower for 
larger websites (> 100 pages). 
 
Generate Search Index 
Enable this option to create the search index during publishing. 
 

Note:  
The search index is required if you want to use the 'Site Search' object on your website! 

 
Name of Index File 
Specifies the name of the search index file. Since this is a JavaScript file, it must have the .js extensions. 
 
Create Index from 
This option specifies how the search index will be created. 
 

• Page Content 
The search index will be created from the content of the page. In this case WYSIWYG Web 
Builder will extract all text from the pages.  

• Meta tags 
The search index will be created from the meta tags you've specified content in Page 
Properties.   

• Text Only 
This will only index the text which result in a smaller/faster search index. In most cases this 
mode will be sufficient. Note that will also decrease the time required to create the search 
index during publishing. 

 
Exclude Stop Words from Index 
Enable this option to exclude stop words. 
WYSYWYG Web Builder includes a predefined list of stop words in the file 'search.dat'. 
To make your own list of 'exclude' words simply copy the file to 'My Documents\WYSIWYG Web 
Builder\system\search.dat and Web Builder will use this file instead. 
 
 

Note:  
Stop Words are words which do not contain important significance to be used in Search Queries. 
Usually, these words are filtered out from search queries because they return vast amounts of 
unnecessary information. 

 
Use absolute links 
Enable this option if you want to use the search engine in sub folders. In that case absolute links must be 
used otherwise the links in the search results will not be using the correct path (because there is only 
one search index at the root of the website). 
 
Example: 
https://www.yourwebsite.com 
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Error Report 
The Error Report tools will analyze the current page and check for errors like duplicated IDs, invalid 
filenames or other common problems. Here's a list of possible problems which are currently detected by 
error report tool: 
 
Invalid filename 
Names must contain only ASCII letters (a-z,A-Z), digits (0-9), underscore, dot and dash. 
  
Empty ID 
Make sure all objects have a valid ID. 
  
Duplicate ID 
All objects must have a unique ID property within the context of the page. This includes the objects on 
master pages! 
  
Invalid HTML 
Custom HTML may not contain <html> <head> or <body> tags. 
  
Invalid page extension 
The page contains a form which requires PHP. Set the page file extension to 'php' (in Page properties) 
  
Success page not specified 
The success page property of the form cannot be empty. 
  
Error page not specified 
The error page property of the form cannot be empty. 
  
Invalid page title 
The page does not have a meaningful title. The page title is either empty or has the default 'untitled 
page' value. 
 
Invalid page name 
The 'index' page should not have uppercase characters in its name.  'Index' or 'INDEX' is invalid. 
 
Form is using 'mailto:' 
Using 'mailto:' in forms is unreliable. Please consider using the built-in form processor instead. 
 
Text is not optimized 
The text is not optimized for all browsers. Consider using one of the compatibility options. 
 
Object is outside the view port 
The object's outline is outside the page boundaries. If the object is hidden then first unhide it, move it 
inside the page boundaries and hide it again. 
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In Page Properties you can select the theme for a page (which then will be applied to all objects on that 
page). And although the Theme Manager was designed to create themes for jQuery UI widgets, other 
objects also support the themes! For example, you can select 'Use page theme' in the menu bar, 
navigation bar, tab menu and many other objects. 
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Global Replace 

The Global Replace tool can be used to quickly change the color, font, URL or filename for all objects (or 
a selection) on the page or entire website.  
 
Pages 
Specifies whether to replace values on the current page only on the entire website. 
 
Breakpoints 
Specifies whether to replace values in all breakpoints or in the current breakpoint only. 
 
Objects 
Specifies the object categories the find/replace will apply to. 
For example: only replace a color value for form elements. 
 
Property 
Specifies what to replace: 

• Color 
Replace a color value with another value. 

• File 
Replace a filename. The tool will automatically list all filenames currently in use. 

• Font Name 
Replace the font name. The tool will automatically list all font currently in use. 

• Font Size 
Replace the font size. 

• URL 
Replace an URL. The tool will automatically list all URLs currently in use. Also supports tel, 
email, facetime, SMS and skype links! 

• (ID) 
Rename the ID of objects.  

• Internal Link 
Replace internal links 
 
Tip: to add a prefix to all IDs of a page, set the old value to * (wildcard) and the new value to 
the prefix. This can be useful to quickly add a prefix to the IDs of master pages/master frames. 
See also: How to prevent duplicate IDs 

 
Note that this action cannot be undone! 
 
Global Replace cannot replace data in extensions. 
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WYSIWYG Web Builder Objects 
In WYSIWYG Web Builder you create your website by dropping objects on the page.  
There are several ways to insert objects: 
 

Insert Tab 
To insert a new object, select one of the available items and draw a box to indicate the position of the 
object. The new object will now be inserted onto the page. To change the properties, double the object 
or select Edit -> Properties from the menu bar. It’s also possible to call the object’s properties using the 
keyboard shortcut ‘Alt+Enter’. 
 

 
 

Toolbox 

Another way to add objects to your page is by simply dragging them out of the toolbox onto the 
workspace. 
 

 
 

Context Menu 
Right click on the page to display the context menu. 
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Style 
Many objects have a style section in the properties window, here you can set the appearance of the 
object. Note that not all options do apply to all objects. For example, some objects do not have 
background or text properties. 
 

 
 
Predefined Style 
Here you can select one of the global site styles. This option will overwrite all custom style settings for 
the object. You can add or edit styles in the Style Manager. 
Note that the <h1> ... <h6> are generally only used for text! 
 
Use Theme 
You can activate theme support for individual objects by using the 'Use Theme' property. When this 
option is turned on, it will supersede the local object color settings. 
 
To enable theme support for all newly created objects, activate 'Enable Use Theme as default for new 
object in Tools -> Options -> General -> Theming 
 
Please see the ‘Theme Manager” chapter for more details. 
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Background 
Background mode 
Specifies the background mode. 
 

• Transparent 
The background of the object will be transparent. 
 

• Solid 
Use a solid background color. 
 

• Image 
Use an image as background. 
Repeat; Sets the tiling attributes for the background image. Possible options are: Repeat in 
both directions, repeat in horizontal direction, repeat in vertical direction and do not repeat. 
Horizontal Align; Sets the horizontal position for the background image.  
Vertical Align; Sets the vertical position for the background image.  
 

• Gradient 
Use a (two-color) gradient as background. This option supports many different gradient styles 
like linear, ellipse, glass, glossy etc. By default, a background image will be generated for the 
gradient effect. However, you can also use CSS3 gradients by enabling the option 'Use CSS3 
gradients instead of images' in Menu -> Tools -> Options -> HTML. Keep in mind however that 
not all browsers support CSS3 yet. 
 

• Multi-color gradient 
Use a (multi-color) gradient as background. WYSIWYG Web Builder includes many predefined 
multi color gradient styles, but you can easily create your own style with the Gradient Style 
Manager. Just like the standard gradient option it supports many different gradient styles like 
linear, ellipse, glass, glossy etc. By default, a background image will be generated for the 
gradient effect. However, you can also use CSS3 gradients by enabling the option 'Use CSS3 
gradients instead of images' in Menu -> Tools -> Options -> HTML. 
 

• Pattern 
Use a pattern as background. A new image will automatically be generated for the pattern.  
 

• Texture 
Use a texture as background. A new image will automatically be generated for the texture.  
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Bookmark 
Text and images can be set as bookmarks (also called "anchors") that can be linked to within a page. For 
example, if a page has several new items, the news titles for each item can be set as bookmarks and a 
row of links can be added to the top of the page that will each skip down to those bookmarked sections. 
This method of using bookmarks allows visitors to your site to quickly access information by not having 
to scroll down the page to view the information they want. 
 

 
 
You can create a Bookmark by using the Bookmark tool from the Insert menu and place it anywhere in 
the page. Make sure you give the bookmark a unique name. Once you have placed the bookmark icon 
on your page, it can be selected from the Bookmark dropdown list.  
 
Enable Smooth Scrolling 
Enable this option to animate the page scrolling. This effect is often used in modern websites. The 
Duration specifies the timing of the animation. Easing can be used to create ‘bounce effects’. 
 
Menu Name 
Specifies the text that will be used for the automatically generated menu items when the option 
'Synchronize with Bookmarks' is enabled. 
 
Events 
The following events are unique to WYSIWYG Web Builder. They make it possible to trigger actions 
based on the scroll position of the page. For example, you can start animations or show/hide objects 
when the bookmark scrolls into (or out of) the viewport. 
 
onscrollreveal 
Fires when the bookmark is completely visible in the view port of the browser. 
 
onscrollrevealpartial 
Fires when the bookmark is partially visible in the view port of the browser. 
 
onscrollhide 
Fires when the bookmark is scrolled out of the browser's view port. 
 
You can read more about bookmarks in the ‘Links’ chapter. 
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Bulleted List 

You can add a bulleted list to your web page to set apart a list of items from the rest of the page pf text. 
The bulleted list is a combination of ordered (numbered) lists and unordered lists and supports the 
following styles: Circle, Disc, Square, Numeric (1, 2, 3), Lower Alpha (a, b, c), Upper Alpha (A, B, C), Lower 
Roman (i, ii, iii), Upper Roman(I, II, III) and custom images. 
 

  
 
To insert a bulleted list into your page, select Insert -> Bulleted List. Next select the initial number of 
items and the bullet style. Note that you can always change the bullet style to something else according 
to the object's properties. 
 
Other properties of the bulleted lists include Font, size, color and spacing and padding for the individual 
items. 
 

How do I edit the text of an item? 
Double click the item to edit the text. Formatting of the text works the same way as in a regular textbox. 
 

 
How do I insert a new item? 
Right click the bulleted list to display the context menu and select Insert Item. 
 

 
How do I remove an item? 
Right click the bulleted list to display the context menu and select Delete Item. 
 

 
How do I select the next item using the keyboard?  
Use the Tab key to go to the next item 
 

 
How do I change the space between the bullet and the text? 
When you move the mouse cursor between the bullet and the text you can drag the (invisible) border to 
increase or decrease the spacing. 
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Heading 

This object provides a quick and easy way to add headings (<h1>, <h2>) without using styles. Each 
heading object can have its own fonts/size/color! 
 
Note that you can also use Styles to insert headings into the standard text objects, but in that case all 
headings in the project will have the same style. 
 
A heading object also can output the heading as paragraph <p>. This can be useful if you want to use 
specific heading features that are not available for standard text like 'text shadow', 'text stroke' or 
variable fonts. 
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Object-fit 
Specifies how the image should be resized to fit its container. This requires a modern browser! For 
example, Internet Explorer does not support this property! https://caniuse.com/#feat=object-fit 
 

• fill  
The image is sized to fill the element's content box. If necessary, the object will be stretched or 
squished to fit.  
 

• contain 
The image is scaled to maintain its aspect ratio while fitting within the element's content box.  
 

• cover 
The image is sized to maintain its aspect ratio while filling the element's entire content box.  
The object will be clipped to fit.  
 

• none 
The image is not resized.  
 

• scale-down 
When the container is smaller than the image, it will be scaled down.   

 
 
Image Tools and Filters 

In WYSIWYG Web Builder, you can apply effects/filters to images without having to open a separate 
image editor! Built-in tools include: 
 
Rotate 
Rotate the image 90 degrees left or right.  
 
Flip 
Flip the image horizontally or vertically. 
 
Contrast 
Adjust the contrast of the image.  
 
Brightness 
Adjust the brightness of the image.  
 
Resample 
Re sampling an image will change the number of pixels and therefore the physical file size of an image. 
Re sampling will be done based on the current size of the image on the page. If the size is smaller than 
the original size, the physical file size is decrease. If it's larger, the file size will increase! 
 
Crop 
By cropping an image, you can remove areas of the image that you don't want to use. While in crop 
mode drag the handles of the cropping box to resize and include the part of the image that you want to 
keep. Click Crop again to remove the area outside of the cropping box. 
 
Slice 
The slice tool is used for "Slicing" up your images into many smaller pieces you will not notice anything 
on your page because when it is previewed all the piece show as one. The logic behind slicing is that 
your images will load faster, and it can also help to stop users from trying to steal your images if the try 
to they won’t get one large image but just one small piece of it. 
 
Hue/Saturation 
Adjust the hue or saturation of the image.  
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Auto thumbnail 
Use this option to quickly create a smaller thumbnail-sized version of the image. A link to the original 
full-size image will be added. 
 
Set Transparent Color 
You can create a transparent area in most images except in animated GIF images.  
Select the image you want to create transparent areas in.  
On the image toolbar or menu click 'Set Transparent Color'.  
In the image, click the color you want to make transparent.  
The Set Transparent Color option is available for images that don't already have transparency 
information. The image will be converted to the PNG format and will be published with a different 
name. 
 
Add/Replace stencil 
Stencils are a cool way to change the appearance of your images. Stencils can convert your images into 
any shape! Basically, stencils replace the alpha channel information (transparency) of the image with the 
one from the stencil. You can create your own stencils and place the stencils in the sub folder ‘stencils’ 
of the program.  
 
Filters 
There are many built-in filters. For example: Blur, Buttonize, Colorize, Droste Effect, Emboss, Inner Bevel 
Frame, Glow, Grayscale, Mosaic Tiles, Negative, Oil Painting, Old Photo, Polaroid Stack, Sepia, Sharpen, 
Texture, Tilt Shift, Water Reflection and much more! 
 
Tips for using filters: 

1. You can apply multiple effects to an image. 
2. Effects are non-destructive, which means they are not applied to the original image. A copy of 

the original image will be published to your website using a unique name (.png format). 
3. Effects are applied to the image 'on-the-fly' when the images are loading into workspace and in 

the order, you've added them. So, for example if you apply Brightness 3 times, the images will 
be processed 3 times the next time you load your page.  

4. Resample can be used to decrease the size of the published image and therefore can increase 
the loading speed of your website. Of course, resampling will also reduce the quality of the 
image. 
 

Watermark  

Watermark Tool is a powerful feature that allows you to quickly and easily protect your images with a 
visible watermark.  With the many watermarking options available, you're able to personalize your 
images in a variety of ways including text size, color, and position. 
 
Support types: 

• None 
The watermark tool will be disabled. 

• Standard 
The text will be rendered at the top of the image. 

• Inverted 
The watermark effect will be inverted. 

• Embossed 
This option will use an emboss effect for the text. 

• HTML overlay 
Adds a text overlay to the image (instead of merging the text with the image).   

• HTML overlay (hover) 
Adds a text overlay to the image which is displayed on mouse over. 
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Marquee 
The Marquee object is used to introduce text that scrolls. 
 

 
 
Text 
Enter the text to scroll. Text can include formatting and links. 
 
Direction 
This attribute controls the direction of scrolling. 
 
Repeat 
Number of times to repeat the scrolling (0=Continuously). 
 
Delay 
This controls the delay (in milliseconds) between the successive displays that give the impression of 
animation. 
 
Amount 
This controls the amount of movement (in pixels) between the successive displays that give the 
impression of animation. 
 
Behavior 
This attribute controls the behavior of the displayed text. 

• scroll 
indicates that the content should scroll off the edge of the marquee area, then reappear on the 
other side. 
 

• slide 
same as scroll, however the text stops scrolling when it reaches the edge of the object 
 

• alternate 
makes the text bounce back and forth. 
 

• star wars 
Implements Stars Wars-like 3D scrolling. 

 
Pause scrolling on mouse over 
Specifies whether to pause scrolling on mouse over. 
 
 

Note:  
The unofficial <marquee> tag has been replaced with CSS3 animations for better compatibility with 
(modern) browsers. W3C compliant! 
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Shortcut Keys 
The text editor supports the following shortcut keys: 
 
 
Keys Operations  Comments  

Ctrl + A Select all  

Ctrl + E Center alignment  

Ctrl + J Justify alignment  

Ctrl + R Right alignment  

Ctrl + L Left alignment    

Ctrl + C Copy    

Ctrl + V  Paste    

Ctrl + X  Cut    

Ctrl + Z  Undo    

Ctrl + Y Redo    

Ctrl + '+' 
(Ctrl+Shift+'=') 

Superscript    

Ctrl + '='  Subscript    

Ctrl + ' (apostrophe) Accent acute  After pressing the short cut key, press the appropriate  
letter (for example a, e, or u). This applies to English,  
French, German, Italian, and Spanish keyboards only.   

Ctrl + ` (grave) Accent grave See Ctrl+' comments.  

Ctrl + ~ (tilde) Accent tilde See Ctrl+' comments.  

Ctrl + ; (semicolon) Accent umlaut See Ctrl+' comments.  

Ctrl + Shift + 6 Accent caret (circumflex) See Ctrl+' comments.  

Ctrl + , (comma) Accent cedilla See Ctrl+' comments.  

Ctrl + Shift + ' 
(apostrophe) 

Activate smart quotes  

Backspace  Delete previous character  

Ctrl + Backspace Delete previous word.  

Ctrl + Insert Copy    

Shift + Insert Paste    

Insert  Overwrite   

Ctrl+Left Arrow Move cursor one word to the 
left. 

 

Ctrl+Right Arrow Move cursor one word to the 
right. 

 

Ctrl+Up Arrow Move to the line above.  

Ctrl+Down Arrow Move to the line below.  

Ctrl+Home Move to the beginning of the 
textbox.   

 

Ctrl+End Move to the end of the textbox  

Ctrl+Delete Delete the next word or selected 
characters. 

 

Shift+Delete Cut the selected characters.  

Esc Stop editing text. Leave edit 
mode. 

 

Alt+0xxx (Number 
Pad) 

Inserts Unicode values if xxx is 
greater than 255. 

When xxx is less than 256, ASCI range text is inserted  
based on the current keyboard.  Must enter decimal values. 

 
Lorem Ipsum 
Lorem ipsum is a placeholder text (filler text) commonly used to demonstrate the graphic elements of a 
web site, such as font, typography, and layout, by removing the distraction of meaningful content.  
WYSIWYG Web Builder has a simple built-in Lorem Ipsum Text generator to add place holder text to the 
text object. You can either insert complete paragraphs or a specific number of words.  
The text will be loaded from a file called loremispum.txt in the application folder. If you like you can edit 
or overwrite this file with your own custom text (for advanced user only!).  
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Form Wizard 
Creating forms has never been so easy! Create complete forms in just a few steps. One of the many 
ways in which you can interact with people who visit your website is to get feedback from them through 
forms. Creating a form from scratch can be rather difficult, so we've implemented the Form Wizard to 
make this task a little easier. 
  

Step 1: How do you want to create the new form? 
The WYSIWYG Web Builder Form Wizard has 3 methods to create a form: 

1. Create a new form based on a template 
This option allows you to select a template form, which you can use as the basis for own form. 
 

2. Create a new form from scratch using the wizard 
Manually insert controls and labels to the form. 
 

3. Create a blank form so you can add controls later 
Insert a blank form to your page with no controls on it. Basically, this is the same as manually 
inserting an empty form area.   
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Step 2: Select a template form 
We've included several ready-to-use forms to get you started. Please take your time to study the 
properties of each of these forms to get an idea how we've implemented them, so you can use this 
knowledge to create your own forms. For some forms you will need to modify the pre-defined values 
such as the specified email address or website URL.  
 
There are 2 form processor templates where external websites are used to process the form data. 
Before you can make use of the services of these websites you will need to register first! 
https://www.formbuddy.com/ 
https://www.mailmyform.com/ 
 
These examples can be useful if your website does not support PHP or any other type of form 
processing. 
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Step 3: Add Control to the form 
In this step you can insert controls to the form. Each control can have a label which will be displayed in 
front of the control. Click Add and select one of the items from the drop-down menu to insert a new 
control. In most cases the wizard will ask you to enter a label name. 
 
To modify the properties of the controls, select it in the list and click Edit to show the control's 
properties. You can re-arrange the items using the Move Up and Move Down buttons.  
  

  
 
 

Tip:  
Make sure your form contains a Submit button. Without this button the user will not be able to submit 
the entered data! 
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Note: 
Some form templates use their own form processor script (usually added as a separate HTML object). In 
that case please do not change the predefined values unless you know what you are doing! 
  
Templates that use a custom form processor include: 
Dictionary lookup 
Form processor: ASP 
Form processor: Godaddy 
Form processor: Tell a friend 
Form processor: Formspree 
Tell a friend 
All PayPal templates 
All search templates 
  
Important: 
Some form templates use hidden fields to specify an email address or website.  
Make sure you replace these values with your own information!!! You can change the values of the 
hidden fields at any time later through the form's properties. 

 
 
Use Built-in PHP form processor to send data to an email address. 
Enable this option if you want to use the built-in form processor.  
For more details about this feature in the Form chapter. 
 
Encoding type 
The required encoding type depends on the form processor script, so please consult the documentation 
of the CGI script for more info. In case you have selected a pre-defined form, the correct encoding type 
will be selected. 
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Form 

A form provides a way for you to collect information from the people who view your web pages. A 
viewer enters data or makes choices among several options and then submits the form. The results can 
be sent to you by email. If your web server has the right software, you can save the form results in a 
database. 
 

 
 
The Form Area object is a container for FORM objects like buttons, edit boxes and checkboxes. You can 
add any standard form object to a form, including single- and multiple-line text fields, check boxes, radio 
buttons, scrolling lists, and drop-down lists.  
 
You should place form objects inside a form to make them work as part of the form. 
 

How do I create a form in WYSIWYG Web Builder? 
1. Drag the Form object to the page and a draw a box to indicate the position of the form. 

 
2. Design your form by adding some Form controls to the form, for example: 

Button, Image Button, Advanced Button, Checkbox, Radio button, Editbox, Text Area or  
Combobox/Select. You can also make text and images part of the form. You'll notice that all 
objects become a part of the form, so when you change the position of the form all those 
objects move along. 
 

3. Make sure your form contains a Submit button (push button). Without this button the user will 
not be able to submit the entered data. 
 

4. Once you have designed your form, you may need to set some properties. Select the form and 
choose Edit -> Properties from the Web Builder menu. The most important thing you need to 
do is specify the form action. For example, to send the entered data to your email address, 
when the user presses the submit button: mailto:yourname@yourdomain.com 

 

Note:  
Much more information about forms is available in the Frequently Asked Questions section of the 
website, in the online tutorials and in the support forum: 
https://www.wysiwygwebbuilder.com/support.html 
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Email address 
The email address where the results of the form will be sent to. You can only specify one email address 
in this field. You can leave this field empty if you do not want to send an email. 
 
More-button 
Click the 'More' button to specify multiple email addresses (CC/BCC). Use commas to separate email 
addresses.  The 'From email' field will set the 'from' address of email sent messages to the specified 
email address. If you leave the field empty, then it will work like in previous versions: either the 'email' 
input will be used (if it exists) or the 'to' address. 
The 'From name' allows you to set the name of the sender. It is also possible to use a PHP variable. For 
example, S_POST[‘name’] where ‘name’ is the name of the input field. 
'Reply to' can be used to specify an alternative reply address. 'Reply To' can be a fixed email address, in 
which case you must use quotes: 
 'yourname@email.com'  
or a PHP variable:  
$_POST['email'] 
 
The default value is $mailfrom. This is a built-in variable and means that if 'From email' has been 
configured that this will be used or else the email address entered by the user. 
 
Subject 
The subject of the email message. 
 
Message 
A short message that will be added to submitted data. 
By default the message will be sent in plain text, but it's also possible to format the text. Click the 'Edit' 
button to change the format of the message. Select 'Rich text' to use the built-in editor to format the 
text (click the 'Edit' button to open the editor) or select 'HTML' to insert your own HTML code for the 
message (for advanced users!). 
 
Success page (required) 
The page that the user will be redirected to after the data has been submitted (after the 'submit' button 
has been pressed). 
 
Error page (required) 
The page that the user will be redirected to if an error occurs while processing the data. 
 
Write form data to a .csv file. 
This option will save the submitted form data to a comma separated data file on the web server. You 
open this file in Microsoft Excel, a text editor or import into a database. 
 
Note that the data file must exist on the server, and it must be writable! 
WYSIWYG Web Builder has a very useful option to automatically create this file for you and set the 
appropriate permissions. Simply click the 'Create' button next to the filename field and follow the 
onscreen instructions. 
 

Step 1 
Enter the name of the data file. For example, 'formdata.csv' 
 
Step 2 
Select the publish location where the file will be created. Web Builder will list all profiles you've 
created in the publish manager. 
 
Step 3 
Web Builder will connect to the selected location and display the folder structure on the web 
server. Select the remote folder and click 'Finish' to create the data file. 
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Upload files to a folder on the server. 
If this option is enabled the built-in form processor will upload files to a folder on the server instead of 
sending them as attachment via email. The files will be saved with a unique filename. The location of the 
uploaded file(s) will be included in the email message. 
 
Database (for advanced users) 
You can use this option in combination with the built-in form processor to store form data in a MySQL 
database on the server. The generated PHP script will attempt to automatically create the table and 
fields based on the settings you configured, so you do not have to worry about creating it yourself. 
The database fields will be in the same order and use the same name as in your form design. 
 

Note:  
To view or process the submitted form data you will need a separate tool, like the standard MySQL 
admin tool. Please consult the documentation of your web host for more details. 

 
Write form data in a MySQL database, specify whether to write form data in a MySQL database.  
Database, specifies the MySQL database name. 
Table, specifies the MySQL database table name. 
Username, specifies the MySQL username. 
Password, specifies the MySQL password. 
Server, specifies the MySQL database server. 
 

Auto responder 
We have added some basic auto responder functionality to the form processor. This allows you to send 
a (thank you or confirmation) message to the user. 
  
From 
Specifies the 'from' email address for the email message. 
 
Subject 
Specifies the subject for the email message. 
 
Message 
Specifies the body text for the email message. 
 
Input field name 
Specifies the name of the email input field. The default is 'email'. Which means that the form should 
have an input field named 'email' to collect the email address. 
 

Miscellaneous 
Enable Include IP address in form data to include the IP address of the computer form where the form 
was submitted in the message. The option Process variables in Success Page makes it possible to 
include form results in success page. This allows you to use variables in the text (or other parts of the 
success page) which will be replaced by the submitted values of the form. 
  
Example: on the success page add a text object with this text: 
 
The following data has been submitted to the online form: 

Name: $name 

Email: $email 

Website: $website 

 
Where name, email and website are the names of the form fields plus dollar sign. So, if the field name is 
'name' then the variable name will be '$name'.  
 
Enable server sided validation 
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Hidden Fields 

You can also add hidden fields that are not rendered but whose values are submitted with a form. 
Generally hidden fields are used to store information between client/server exchanges that  
would otherwise be lost due to the stateless nature of HTTP.  
 

 

Events 
For more information about events please read the ‘Events’ chapter of this document. 
 

 

Web Storage 

Web storage is a new feature of HTML5. It allows you to store field values between sessions or/and 
pages.  This can be useful if you want to transfer values from one form to another. 
Enable this option and WYSIWYG Web Builder web builder will automatically store and retrieve all 
values for you! 
Note that the ID of the objects will be used as the key for the value, so if you want to retrieve the values 
in another form (on another page) then it must have the same ID. 
 
Local storage stores data with no time limit. 
Session storage stores data for one session. 
 
Note:  
Web storage only works if your website is online. It works in all modern browsers. 
 
  

Set Tab Order in Forms 
The option 'Set Tab Order' can be used to quickly set the Tab order in forms. 
Here's how it works: 
1) First select the form. 
2) Next select the 'Set Tab Order' option in the menu (also available in the context menu of the form). 
3) Web Builder will now display the current index of each form element that supports the tab index 
attribute. If the tab index is not set yet, it shows 'Not Set'. 
4) Now click each object in the desired order. The new index will automatically be displayed. 
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Advanced Button 

 

 
 
Inserts an Advanced Button object on a form. The Advanced Button gives you more control over the 
appearance and behavior than a standard button. You can change the background color, use different 
fonts for the text or even activate JavaScript. 
 
Name 
Name of the button. 
 
Value 
Initial value of the button. 
 
Button Type 
Normal: Normal (Push) buttons have no default behavior.  
Submit: When activated, a submit button submits a form.  
Reset: When activated, a reset button resets all controls to their initial values.  
OnClick: With this option you can associate a client-side script to the button.  
 
OnClick action 
Here you can specify which action if associated with the button OnClick event: 

• Navigate to the specified URL; enter an URL as OnClick value 

• Open a new window and load the specified URL Close the current browser window; enter an 
URL as OnClick value 

• Reload; reload the current page (same as Refresh in the Internet Browser). 

• Go to the previous page; the same as Back in the Internet Browser. 

• Go to the next page; the same as Forward in the Internet Browser. 

• Execute Java Script function; specify a script function you've defined elsewhere in the page. 
 
OnClick value 
Depending on which OnClick action you've selected you enter the associated value here. 
For example, to Navigate to the specified URL you enter an URL. 
 
Access Key 
This attribute assigns an access key to the object. An access key is a single character. 
Pressing the access key gives focus to the element. 
 
Disabled 
The disabled option disables the control for user input. Disabled controls do not receive focus.  
 
Tab Index 
All elements (except hidden elements) in a form are part of the form's tab order.  
 
Title 
Specifies the tooltip displayed by the browser 

 

Events 
For more information about events please read the ‘Events’ chapter of this document. 
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Width / Height 
Specifies the width and height of the image. 
 
Text Color 
Specify the color of the text. Select 'Random' to use a random color for each character. 
It's also possible to set the transparency of the text, so the background will shine through. 
 
Background Effect 

• solid 
Use a solid background color  

• random 
Generate a random background with polygons and lines in different colors which is more 
difficult to read by spam bots. 

• noise 
Generate a random background noise effect. 

• dots & lines 
Generate a random background with dots and lines  

 
Enable wave effect. 
This will apply a wave filter to the image to make it harder to read for spam bots. 
 
Enable rotation 
Specifies whether to use randomly rotated characters. 
 
Enable text shadow 
Adds shadow to the text, making it even more difficult to read for spam bots (but also for humans...). 
 
Include characters 
Specify which characters will be used in the image. Avoid using confusing characters and numbers (For 
example: l, 1 and i) 
 
Secret Key/ Site Key 
Enter your Site and Secret reCAPTCHA key here.  

 
Editbox Offset 
Specifies the offset between the image and the editbox. 
 
Tips:  
If you enter a negative value, then the editbox will be positioned below the image! 
It's also possible to hide the standard editbox (set offset to -99). This allows you to create your own 
input control to give you more control over the size, position and styling. 
 
Access key 
This attribute assigns an access key to the object. An access key is a single character. 
Pressing the access key gives focus to the element. 
 
Tab Index 
You can set the tab order of the form fields using tabindex attribute. Usually, the first tabindex starts 
with value '1'. To exclude an element from the tab order, set the value of tabindex to 0. In that case the 
element is skipped when the user tabs around the form. 
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Checkbox 

 

 
 
Checkboxes are on/off switches that may be toggled by the user. Use Check boxes if want to allow more 
than one item to be selected. 
 
Name 
Specify the name of the checkbox. 
 
Value 
The value of the checkbox when it's switched on. 
 
Initial state 
Initial state of the checkbox. 
 
Access Key 
This attribute assigns an access key to the object. An access key is a single character. 
Pressing the access key gives focus to the element. 
 
Disabled 
The disabled option disables the control for user input. Disabled controls are skipped in tabbing 
navigation. The value of disabled controls will not be submitted with the form. 
 
Title 
Specifies the tooltip displayed by the browser 
 
Style 
Default, uses the default browser style. This style cannot be customized. 
jQuery UI, uses a jQuery UI chekcbox 
Bootstrap, uses Bootstrap checkbox 
 
 

Validate 
For more information about validation please read the ‘Form validation’ chapter. 
 

Events 
For more information about events please read the ‘Events’ chapter of this document. 
 

Note:  
This control is normally part of a form. 

 



WYSIWYG Web Builder 20   

117 

Select 

  
 
Used to allow users to select from several different options. 
 
Name 
Enter an identifier for the field. 
 

Note:  
It's important to note that the element name must be in the form name[] for multiple selects! This way 
you'll receive the selected values in an array (this is a PHP feature). 

 
Type 

• Combobox 
This will make the object a drop-down list. Only a single line is displayed at once. 

• Listbox 
This will make the object a standard list box. Multiple lines are displayed at once. 

• Datalist (HTML5).  
A datalist is a combination between a combobox and an editbox. The user can select data from 
a list or enter the value manually. 

 
Allow multiple selections 
Allows the user to select multiple items at the same time. 
 
Elements 
You can Add, Edit and Delete items that will appears in the list. 
 
Add 
Add a new item to the list. 
 
Edit 
Edit an existing item in the list. 
 
Delete 
Remove the selected item from the list. 
 
Import 
This option allows you to quickly import lists of predefined data. Select from many predefined values 
(countries, states, months, days etc.) or import from an external file. 
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Import from external file 
The file with items must have two items per line, separated by a semi colon: Item Text;Item Value 
 
For example: 
Afghanistan;Afghanistan 
Albania;Albania 
 
Move Up 
Moves the selected item up one position in the list. 
 
Move Down 
Moves the selected item down one position in the list. 
 
Disabled 
The disabled option disables the control for user input.  
Disabled controls do not receive focus.  
Disabled controls are skipped in tabbing navigation.  
The value of disabled controls will not be submitted with the form. 
 
Tab Index 
All elements (except hidden elements) in a form are part of the form's tab order.  
When the user presses the Tab key, the browser shifts the input focus from element to element in order 
that the elements appear in the HTML code. However, sometimes you want the tab order to flow a little 
differently. In that case, you can number the fields using tab index attribute. 
Usually, the first tab index starts with value '1'. To exclude an element from the tab order, set the value 
of tab index to 0. In that case the element is skipped when the user tabs around the form. 
 
Title 
Specifies the tooltip displayed by the browser 
 
Focus state 
Removes the default outline styles and applies a box-shadow (with customizable color) in its place. 
 
Floating label 
With floating labels, you can insert the label inside the input field, and make it float/animate when you 
click on the input field. This option uses the 'Title' for the label. 

 
Validate 
For more information about validation please read the ‘Form validation’ chapter. 
 

Conditions 
For more information about conditions and calculations please read the ‘Form Conditions’ chapter. 
 

Events 
For more information about events please read the ‘Events’ chapter of this document. 
 

Note:  
This control is normally part of a form. 

 



WYSIWYG Web Builder 20   

119 

Editbox 

Single-line field that can be used to add name/e-mail address fields. 

 

 
 
Name 
Enter a name for the input field. 
 
Initial Value 
Value that is initially display in the input field. 
 
Place holder 
Specifies a short hint to help the user to fill out the input field. The text will disappear as soon as the 
user enters some text. 
 
Max. Length 
Specifies the maximum number of characters a user can enter in the editbox. 
 
Type 

• text 
A plain text field.  

• password 
Makes the editbox a password field so any text entry is displayed as asterisks.  

• color (HTML5) 
The browser displays a visual color picker.  

• date (HTML5) 
The browser displays a date picker.  

• datetime (HTML5) 
Input field is for precise, absolute date and time stamps.  

• datetime-local  (HTML5) 
Input field is for local dates and times.  

• email  (HTML5) 
Input field is for email addresses.  

• month  (HTML5) 
The browser displays a month picker.  

• number (HTML5) 
The browser displays a visual spin box.  

• range  (HTML5) 
The browser displays a range selector.  

• search (HTML5) 
The browser displays a search input field.  

• tel (HTML5) 
The browser displays a telephone input field.  

• time  (HTML5) 
Input field is a time input field.  

• url (HTML5) 
Input field is for web addresses.  

• week  (HTML5) 
The browser displays a week picker.  

 
Note: Different browsers will have different behavior. Some input types may not be fully supported by 
all browsers. 
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Disabled 
The disabled option disables the control for user input. Disabled controls do not receive focus. Disabled 
controls are skipped in tabbing navigation. The value of disabled controls will not be submitted with the 
form. 
 
Access Key 
This attribute assigns an access key to the object. An access key is a single character. Pressing the access 
key gives focus to the element. 
 
Auto complete 
Specifies whether the input field should have auto complete enabled (if available in the browser). 
 
Spellcheck 
The HTML5 spellcheck attribute specifies whether the element is to have its spelling and grammar 
checked or not. 
 
Read only 
The read only option prevents the user from changing the value of the field, but not from interacting 
with the field. The user can still highlight the text for copying for example. Read-only elements receive 
focus but cannot be modified by the user. Read-only elements are included in tabbing navigation. Read-
only elements will be submitted with the form. 
 
Tab Index 
You can set the tab order of the form fields using tabindex attribute. Usually, the first tabindex starts 
with value '1'. To exclude an element from the tab order, set the value of tabindex to 0. In that case the 
element is skipped when the user tabs around the form. 
 
Title 
Specifies the tooltip displayed by the browser. 
 
Focus state 
Removes the default outline styles and applies a box-shadow (with customizable color) in its place. 
 
Floating label 
With floating labels, you can insert the label inside the input field, and make it float/animate when you 
click on the input field. This option uses the 'Place Holder' text for the label. 
 
 

Note:  
This control is normally part of a form. 
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File Upload 

 

 
 
This object provides a means for users to attach a file to the contents of the form. The element is 
rendered as a text field and an associated button, though in some browsers it may appear differently. 
For example: the text of the 'browse' button will be 'Choose' in Opera and 'Browse' in IE/FireFox. Also, 
there is no way to control the size of the button or edit field through HTML. 
 

Notes: 
When using the built-in PHP form processor, the generated script will automatically take care of 
attaching the selected file(s) to the email message after the form has been submitted.  
 
Most hosting services limit upload size to between 2 and 4 Mb. While you can control the upload limit 
by adding an hidden field called 'filesize' with the size in kB, it will nevertheless comply with the limits 
imposed by the hosting providers. 
 
If you choose not to use the built-in form processor, then you must implement a script to handle file 
uploads yourself! 

 
Name 
Enter a name for the input field. 
 
Disabled 
The disabled option disables the control for user input. Disabled controls do not receive focus. The value 
of disabled controls will not be submitted with the form. 
 
Access Key 
This attribute assigns an access key to the object. An access key is a single character. 
Pressing the access key gives focus to the element. 
 
Title 
Specifies the tooltip displayed by the browser. 
 
 
 

Note:  
This control is normally part of a form. 
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Flipswitch 

 

 
 
A "Flip Switch" (also known as Toggle switch) can be used as alternative for a checkbox. Inspired by the 
iPhone checkbox.  
It is possible to use different colors (text/background/border) for checked/unchecked, add animations, 
conditions and events. See also: Checkbox 
 

 
Dark Color Scheme Toggle 
The flipswitch can also be used to toggle between light and dark color scheme by using 
'darktheme_switch' for the ID property.  
Not only does this change the color scheme but it also stores the current state and reloads it when you 
revisit the page (or another page that includes the flipswitch) later! 
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Button 

 

 
 
The push button will usually be used as submit or reset button on a form.  
If the push button isn't part of a form, it doesn't do anything by default.  

 
Name 
Name of the button. 
 
Value/Label 
Caption of the button. 
 
Button Type 
Submit: When activated, a submit button submits a form. A form may contain more than one submit 
button.  
Reset: When activated, a reset button resets all controls to their initial values.  
Normal: Normal (Push) buttons have no default behavior.  
Each push button may have client-side scripts associated with the element's event attributes.  
When an event occurs (e.g., the user presses the button, releases it, etc.), the associated script is 
triggered.  
 
Disabled 
The disabled option disables the control for user input.  
Disabled controls do not receive focus.  
Disabled controls are skipped in tabbing navigation.  
The value of disabled controls will not be submitted with the form. 
 
Access Key 
This attribute assigns an access key to the object. An access key is a single character. 
Pressing the access key gives focus to the element. 
 
Tab Index 
You can set the tab order of the form fields using tabindex attribute. Usually, the first tabindex starts 
with value '1'. To exclude an element from the tab order, set the value of tabindex to 0. In that case the 
element is skipped when the user tabs around the form. 
 
Title 
Specifies the tooltip displayed by the browser 
 
 

Note:  
This control is normally part of a form. 
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Radio button 

 

 
 
Radio buttons are like checkboxes except that when several share the same name, they are mutually 
exclusive: when one is switched "on", all others with the same name are switched "off".  
 
Group Name 
The Radio Button will be part of this group. 
Radio buttons with the same group name will force the user to select one choice. 
 
Value 
Value of the radio button when it is selected. 
 
Initial state 
Initial state of the radio button. 
 
Disabled 
The disabled option disables the control for user input.  
Disabled controls do not receive focus.  
Disabled controls are skipped in tabbing navigation.  
The value of disabled controls will not be submitted with the form. 
 
Access Key 
This attribute assigns an access key to the object. An access key is a single character. 
Pressing the access key gives focus to the element. 
 
Title 
Specifies the tooltip displayed by the browser 
 
Style 

• Default 
uses the default browser style. This style cannot be customized. 
 

• jQuery UI 
uses a jQuery UI checkbox 
 

• Bootstrap 
uses Bootstrap checkbox 

 
 

Note:  
This control is normally part of a form. 
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Range 

 

 
The 'Range' object implements a slider-like control for entering numbers. It can be used as a value input 
field in forms. You can set a min and max value and steps to define the number intervals.  
 
The object also supports events and conditions. With conditions, the range can be linked with another 
input field, for example an editbox to display the selected value. 
 
Name 
Enter an identifier for the field. 
 
Value 
Value that is initially display in the field. 
 
Minimum Value 
Specifies the minimum value of the range. 
 
Maximum Value 
Specifies the maximum value of the range. 
 
Step 
Specifies the number intervals. For example: 0.5 or 2 
 
Disabled 
The disabled option disables the control for user input.  
Disabled controls do not receive focus. Disabled controls are skipped in tabbing navigation.  
The value of disabled controls will not be submitted with the form. 
 
Access Key 
This attribute assigns an access key to the object. An access key is a single character. 
Pressing the access key gives focus to the element. 
 
Tab Index 
Specifies the tab index. 
 
Title 
Specifies the tooltip displayed by the browser. 
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TextArea 

 

 
 
A Text Area is a multi-line form field where the user can enter large amounts of text.  
 
Name 
Enter an identifier for the input field. 
 
Initial Value 
Value that is initially displayed in the field. When the form is submitted the new or edited text is 
entered. 
 
Disabled 
The disabled option disables the control for user input. Disabled controls do not receive focus.  Disabled 
controls are skipped in tabbing navigation. The value of disabled controls will not be submitted with the 
form. 
 
Access Key 
This attribute assigns an access key to the object. An access key is a single character. 
Pressing the access key gives focus to the element. 
 
Spellcheck (HTML5) 
The HTML5 spellcheck attribute specifies whether the element is to have its spelling and grammar 
checked or not. 
 
Read only 
The readonly option prevents the user from changing the value of the field, but not from interacting 
with the field. The user can still highlight the text for copying for example. Readonly elements receive 
focus but cannot be modified by the user. Readonly elements will be submitted with the form. 
 
Tab Index 
You can set the tab order of the form fields using tabindex attribute. Usually, the first tabindex starts 
with value '1'. To exclude an element from the tab order, set the value of tabindex to 0. In that case the 
element is skipped when the user tabs around the form. 
 
Title 
Specifies the tooltip displayed by the browser. 
 
Floating label 
With floating labels, you can insert the label inside the input field, and make it float/animate when you 
click on the input field. This option uses the 'Place Holder' text for the label. 
 
 

Note:  
This control is normally part of a form. 
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File Publisher 

This component automatically uploads the specified files to your web site and creates the folders once 
you publish this page. The files will be published to the same location as the page itself. You can use 
drag & drop to rearrange items. 
 
This object can be helpful if you want to include extra files which are part of the page (like scripts or 
multimedia files). 
 

 
 
Add Files  
Add one or more files to the tree.  
 
Add Folder 
Insert a complete folder and all files it contains from your local disk. 
 
New Folder 
Adds a new folder name to the tree.  
 
Properties 
Modify the properties (folder name or file location) of the selected item. 
 
Remove 
Remove the selected item from the folder tree. 
 
Remove All 
Remove all items from the folder tree. 
 
Do not include files in Asset Manager 
If the option ‘Let WYSIWYG Web Builder manage images and other files used by a project’ in Options is 
enabled, then all files will be copied to the project folder by Web Builder’s Asset Manager. You can 
disable this behavior for this extension by enabling this option.
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Plyr Video Player 

This object was previously called Flash Video Player. However, most browsers no longer support Flash, 
which makes using Flash Video unreliable in modern websites. The video player now uses Plyr which is a 
responsive, customizable HTML5 video player. 
 

 
 
Video 
Specifies the video to be played. 
 
Image 
Specifies the 'teaser' image. This will be displayed if the video is not playing. 
 
Title 
Specifies the title of the video. This will be displayed in the player if the user clicks the 'Info' button. 
 
Description 
Specifies the description of the video. This will be displayed in the player if the user clicks the 'Info' 
button. 
 
Auto start 
To play the movie automatically when the site visitor opens the page, select Auto Start. 
 
Loop 
To replay the movie when it ends, select Loop. 
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HTML 
This object can be used to insert custom HTML code or JavaScript. 
When you add HTML using this object it will be placed at the location where you positioned the object.  
 
Description 
This is used for display in Web Builder only. It can help you identify the code block you've added. 
 
The Type property specifies how and where the HTML code will be inserted in the page. 
 

• Do not use <div> 
Select this option to insert the HTML code “AS IS”, without size and position information. 
 

• Use <div> to set position and size of the HTML 
Select this option to insert the HTML code inside a DIV container with size and position.  
<div style:left:10px;top:10px;width:200px;height:200px;position:absolute"> 

<-- your html --> 

</div> 

 

• Start of Page 
The HTML will be inserted before all other code on the page. 
<-- your html --> 

 <!doctype html> 
<html> 

<head> 
 

• Between <head></head> tags 
The HTML will be inserted between the <head></head> tags. 
<head> 

... 

<-- your html --> 

</head> 

 

• Inside <body> tag 
The HTML will be inserted inside the <body> tags. 
<body attribute=value> 

 

• After <body> tag 
The HTML will be inserted after the <body> tags. 
<body> 

<-- your html --> 

... 

</body> 
 

• Before </body> 
<body> 

... 

<-- your html --> 

</body> 
 

• End of page 
<body> 

... 

</body> 

<-- your html --> 

 

• Inside <html> tag 
<html your html> 

 

• CSS in media query 
This option makes it possible to add breakpoint specific CSS styles. This can be useful if you 
need different styles in breakpoints. 
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Java 
Java applets are an efficient way to add sound and animation, such as scrolling messages and other cool 
effects, to a page. Java applets are platform-independent applications with compact file sizes.  
Most browsers are Java-compatible, so site visitors don’t need special plug-ins to run a Java applet. 
The Java Object makes it easy to insert Java Applets to your page and set their properties.  
To choose appropriate properties settings, you should be familiar with Java before you add these types 
of application files to your site.  





WYSIWYG Web Builder 20   

134 

Layer 

Layers can be used to create advanced layouts. A layer is a container for other objects.  
Objects can be dragged and dropped on a layer just like on a form. 
 
Some of the useful features of layers are:  

• 0...100% transparency  

• Show/Hide a layer (and all its contained objects) using the layer manager or through events. 

• Position and size a layer relatively  

• Position a layer absolute to the right and/or bottom border of the browser window  

• Several background repeat and alignment options.  

• Sticky layer mode, keeps a layer visible at all times. 
 
Opacity   
Change the transparency (0 - 100%) of the layer (and all its children). 
 
Box Sizing 
The box-sizing property is used to tell the browser what the sizing properties (width and height) should 
include. Should they include the border-box or just the content-box (which is the default value)? be 
The 'border-box' option is especially useful for full width layers, where you usually want the border 
inside the view port. With content-box the border size will be added to the total width (> 100%). 
 
Semantic HTML5 
Specifies whether to use semantic HTML5 tags instead of generic <div>. Available options: <article>, 
<aside>, <footer>, <header>, <nav>, <section>. 
 
Overflow 
This overflow can be used to control the overflow behavior of the layer. 
 

• None 
The content of the layer is fully visible. In this case the size of the layer cannot be smaller than the 
content. 

• Hidden 
The content is clipped, but the browser does not display a scrollbar to see the rest of the content. 

• Scroll 
The content is clipped, but the browser displays a scrollbar to see the rest of the content. This can 
be useful to create scrollable content without the need for an inline frame! 

• Auto 
If the content is clipped, the browser will display a scrollbar to see the rest of the content. 

 
 

Note:  
To create/update the content of the layer, you must resize it in the designer so all objects will be visible. 
After you've created/updated the layout you can resize the layer to the desired size.  
You cannot scroll the contents of the layer inside Web Builder. 
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Layout Grid 

The Layout Grid can be used to create flexible multi column layouts that automatically adapt to the 
screen size. A grid can have up to 12 columns, with sizes in percentages. Objects that are dragged onto a 
grid will automatically become floating, which means that they are placed next to each other (from left 
to right) depending on the available space. If the object does not fit on the current row, then it will be 
wrapped to the next row. Some objects (like images, text, blog, photo gallery) can be full width, so they 
always take up the entire row and stretch or shrink when the page size changes. For smaller (mobile) 
screens all columns are stacked based on the defined breakpoint. This is a great new way to create 
flexible and responsive (Bootstrap-like) layouts! 
 

 
 
Layout 
The grid can be configured as fixed or fluid layout. A fixed grid will have fixed columns based on the 
design time width of the grid. The layout will be centered in the viewport. A fluid grid uses the full width 
of the browser window, and all columns will be resized accordingly. 
 
Gutter Width 
The gutter width specifies the spacing on each side (left/right) of a column. 
 
Padding 
Padding (top/bottom) can be used to create spacing at the top or bottom of the layout grid. 
 
Breakpoint 
The breakpoint specifies at which viewport width when the layout will be switched to mobile/stacked 
layout. 
 
Maximum Width 
Specifies the maximum width of the layout grid in the browser window. This can be useful to prevent 
items from being stretched too wide. If the browser window is wider than the specified width, then the 
grid will be centered. 
 
Column Height 
The column height specifies whether the height of the grid columns is variable, fixed or full screen. 

• Auto 
the column height depends on the content inside the grid. 
fixed  
the column height is fixed. If the column has a background, then the entire column will be 
filled. 

• 100vh  
the column height is 100% of the viewport height (full screen). 
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Flex Container 

Flexbox is a new CSS layout mode that introduces a powerful way to lay out, align and distribute objects. 
Flexbox consists of flex containers and flex items. 
Flex items (the objects inside a flex container) can be laid out horizontally or vertically, aligned and 
distributed in various ways. It is also possible to stretch or shrink objects to fill the available empty 
space. Besides the settings in the flex container, each object also has its own flexbox settings which can 
be set via Menu -> Arrange -> Flexbox. 
 
Flex Direction 
The flex-direction property specifies the direction of the flexible items inside the flex container.  
 

 
 

• row 
The default value of flex-direction is row (left-to-right, top-to-bottom). 

• row-reverse 
The flex items will be laid out right to left. 

• column 
The flex items will be laid out vertically. 

• column-reverse 
Same as column but reversed. 

 
Note that if you change the direction of the page in the Page Properties to right-to-left (rtl) then all 
directions will be reserved! 
 
 
Flex wrap 
The flex-wrap property specifies whether the flex items should wrap or not, if there is not enough room 
for them on one flex line. 
 

 
 

• nowrap 
The flexible items will not wrap. 

• wrap 
The flexible items will wrap if necessary. 

 



WYSIWYG Web Builder 20   

142 

Justify content 
The justify-content property horizontally aligns the flexible container's items when the items do not use 
all available space on the main-axis. 
 

 
 

• flex-start 
Items are positioned at the beginning of the container. 

• flex-end 
Items are positioned at the end of the container. 

• center 
Items are positioned at the center of the container. 

• space-between 
Items are positioned with space between the lines. 

• space-around 
Items are positioned with space before, between, and after the lines. 

 
 
Align items 
The align-items property vertically aligns the flexible container's items when the items do not use all 
available space on the cross-axis. 
 

 
 

• flex-start 
Items are positioned at the top of the container. 

• flex-end 
Items are positioned at the bottom of the container. 

• center 
Items are positioned at the center of the container (vertically). 

• stretch 
Items are stretched to fit the container. 
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Grid Editor 
Double click the flex grid to open the grid editor. 
 
Columns / Rows 
Specifies the number of rows / columns in the grid. 
 
Column / Row gap 
Specifies the size of the gap between the rows / columns in a grid layout. 
 
Maximum width 
Specifies the maximum width of the flex grid in the browser window. This can be useful to prevent items 
from being stretched too wide. If the browser window is wider than the specified width, then the grid 
will be centered. 
 
Examples 
This drop-down menu has a few example layouts, which can be used as template for your own layouts. 
Selecting an item in the list will overwrite the current settings. 
 
Enable Visual Grid editor 
The visual flex grid editor provides a user-friendly interface for effortlessly arranging grid items in 
specific row or column structures. You can easily add rows and columns using the '+' and '-' buttons 
located at the right and bottom of the grid, respectively. When you hover over an item, controls appear, 
allowing you to manage its appearance within the grid. Adding new grid items is as simple as clicking the 
'+' button, while existing items can be resized using arrow buttons. Furthermore, removing an item is 
quick and convenient with the 'Delete' button. 
 

 
 
 
 
The following properties will be displayed depending on the current selection in the grid editor: 
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Embedded Page 

Embedded Page (also known as ‘Master Objects’) is a useful feature, which allows you to re-use objects 
from another page (from your web site) in the current web page. An embedded page is basically a 
pointer to the objects of another page (e.g. the 'Master Page"). These objects will be embedded in the 
page exactly as they are on the original page. You can even use multiple master page objects on a single 
page! Let's say you have a certain layout which is the same for all your pages and you don't want this 
copy/paste it between all your pages; then simply create the layout once in page and insert the layout of 
that page in all your other pages using the embedded page object. When you want to update the layout, 
you will only have to do this once on the original page. 
 
Here is an example: 

1. Create a new website, Web Builder automatically adds the first page called 'index'. 
2. Insert a new page using the Site Manager and rename it to 'master_page’. 

 

 
 

3. Now let's add a navigation bar to the master page. Insert -> Navigation -> Navigation bar. 
 

 
 

4. Switch back to the index page (click on the index tab) and insert a ‘Embedded Page’ object. 
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5. Double click the object you have just inserted to select a page. Next click the Select-button to 
display the Select Page window and choose master_page from the list. Click OK to return to the 
page. 
 

 
 
You will notice that the navigation bar of your master_page now has become a part of the 
index page. If you go back to the master page and you modify something in that page, it 
automatically is updated in the index page as well. Of course, this feature is not limited to 
navigation bars only; you can add any element to the master page. 

 
Notes: 

1. Place all objects on the master page aligned to the left and top border, so you do not have any 
margins. 

2. If you use the master_page only for master page purposes and not as standalone page, you can 
enable 'Don't Publish this page' in Page Properties, so the page won't be published when the 
entire website is published. 

3. In contrast to inline frames, when using the Embedded Page object, all objects from that page 
are merged in the current page as if they are really a part of the page. You must however edit 
them in the master page. 

4. Embedded Page objects do not clone the properties of a page! Only objects on the master page 
will be cloned.  

5. Since the objects are cloned "AS IS", make sure the IDs of objects on the master page are 
unique. You can change the ID in the Properties Inspector. It's good practice to give them a 
prefix, like ‘master_’. This will prevent duplicated IDs on a page.  

6. Forms do not work on a master page.  
7. Layer can be used on a master page. However, you cannot use internal links on that layer. 
8. The embedded page should be in the same folder as the pages that are using it. This is 

especially important if you are using internal links because the links will be relative to the 
master page so if the page is in another folder, then they are not valid. 

9. The option 'Use hover state style to indicate the current page' in navigation tools will not work 
in combination with embedded pages, because there will be only one set of images for that 
object. The same images will be used on all pages. 

 
 
Embed as a layer 
When the "Embed as a layer" is selected, all the elements that make up the master page are, in fact, on 
a layer. This layer will block access to any page elements "beneath" it (in the z-order). If the master 
objects layer is on top of a button or link, visitors to your site will not be able to click on the button or 
link even if it is visible.  
 
When the "Embed as a layer" box is unchecked, the elements that make up the master page are 
inserted as individual objects on the page (not on a layer). You can then access any objects "beneath" 
the embedded objects (if they are visible). 
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Content Place Holder 

The Content Place Holder object should be inserted on a Master Frame page. It defines where the 
content of the page will be inserted. 
 
Overflow 
Specifies what will happen if the content of the page is larger than the size of the content placer holder. 

• Expand 
The place holder will automatically expand so that the content will fit without the need for 
scrollbars. All objects below and on the right side of the place holder will be repositioned. 

• Hidden 
Content that does fit inside the place holder will be hidden. 

• Scroll 
Scrollbars will be added if the content does not fit inside the place holder. 

 
Align 
Specifies how the content of the page will be aligned inside the place holder if it's smaller than the size 
of the content place holder. 
 

Master Frames 

A Master Frame is a design concept where your website has a constant frame and only the inner part of 
the page’s changes. In WYSIWYG Web Builder you only must design the frame once and then reuse it in 
all other pages. You can even automatically expand the layout if the content is larger than the content 
place holder! If the content is smaller than the place helper there is also an option to center, it in the 
area. 
 
A master frame page can be any page in your website. To indicate the position where the content of the 
master frame must go, you must insert a Content Place Holder object to the master frame page. 
During preview/publish this content place holder will be replaced with the actual content of the page. 
 
To indicate that a page must use the master frame, you must configure it in the Miscellaneous settings 
of the Page Properties. 
 
The master frame and content page will be merged into one page when it is preview/published. 
Note that the footer has been automatically repositioned because the page content was larger than the 
content place holder! All objects below and at the right side of the content place holder object can be 
repositioned automatically. You can also select to display scrollbars instead. 
 

 
 

Master Frame with Content Place Holder Page Content 
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Result in browser window, the master frame merged with the content of the page. 

 
Notes: 

• The objects on a master frame are cloned "AS IS", so make sure the IDs of objects on the master 
page are unique.  

• You can change the ID in the Properties Inspector. It's good practice to give them a prefix, like 
master_, this will prevent duplicated IDs on a page. 

• We do not recommend using a master frame as part of another master frame to prevent 
infinite loops. 

• The option 'Use hover state style to indicate the current page' in navigation tools will not work 
in combination with master objects, because there will be only one set of images for that 
object. The same images will be used on all pages. 

• The master frame should be in the same folder as the pages that are using it. This is especially 
important if you are using internal links, because the links will be relative to the master frame 
so if the page is in another folder, then they are not valid. 
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Page Footer 

The Page Footer can be used to add a full width footer to your website. Basically, this object is a 
simplified layer, so most settings are identical and other objects can be dragged on top of this object to 
make then part of the footer. The footer will always be displayed at the bottom of the page. 
 
Mode 
Specifies the footer mode. 

• Default 
The footer will be positioned at the bottom of page. Note that this is not necessarily the 
bottom of the browser window.  
 

• Fixed 
The footer will be fixed at the bottom of the browser window.  
 

• Fullscreen 
The footer will be hidden by default and become visible when the user moves the mouse over 
the footer. So, the footer is only visible when needed. This mode also supports animations to 
slide or fade the footer into view. The animation can be synchronized with the header 
animation so both header and footer show/hide at the same time.   
 

• Floating 
The position of the footer will depend on other floating objects (like layers), but it will always 
be at the bottom.  

 
Stack Level 
Specifies the stack level of the footer relative to the page content. The footer can either be 'In front of 
the content' or 'Behind the content'. 
 
Styling, alignment, and other options are the same as for the Layer object. 
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Page Header 

The Page Header can be used to add a full width header to your website. 
Basically, this object is a simplified layer, so most settings are identical and other objects can be dragged 
on top of this object to make then part of the header. The header will always be displayed at the top of 
the page. 
 
Mode 
Specifies the header mode. 

• Default 
The header will be positioned at the top of page. Note that this is not necessarily the top of the 
browser window.  
 

• Fixed 
The header will be fixed at the top of the browser window.  
 

• Fullscreen 
The header will be hidden by default and become visible when the user moves the mouse over 
the header. So, the header is only visible when needed. This mode also supports animations to 
slide or fade the header into view.   
 

• Floating 
The position of the header will depend on other floating objects (like layers), but it will always 
be at the top.  
 

• Hide on scroll 
Implements a popular feature where a sticky header is hidden on scroll-down and shown on 
scroll-up. Include supports for fade and slide animations with easing. 
 

 
Stack Level 
Specifies the stack level of the header relative to the page content. The header can either be 'In front of 
the content' or 'Behind the content'. 
 
Styling, alignment and other options are the same as for the Layer object. 
 
 
 



WYSIWYG Web Builder 20   

154 

Wrapping Text 

One of the most requested features is the possibility to wrap text around images and other objects. 
Unfortunately, this functionality is very complicated to implement because the size and position of text 
is usually not the same in different browsers.  
 

 
 
The results with standard HTML/CSS are unpredictable and not what-you-see-is-what-you-get. Although 
future versions of HTML/CSS will support more flexibility, we decided to simulate the wrapping 
functionality for now and when browsers are ready for it we will convert it to the official standard. 
 
'Wrapping Text' is an object container (just like a layer and form) with text. By default, the text will fill 
the entire box, but when you drag & drop objects inside the 'Wrapping Text' object then the text will 
wrap around it! 
 
All text will have the same formatting which can be configured in the Style properties. Because not all 
fonts behave the same way in different browsers, we have added a 'font fine-tune' option which allows 
you to fine-tune the size of the font for the best results. Make sure you test this in all browsers! 
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Media Player 

Use this object to add media files to your page. This is the most common way to add media files to your 
web page. The Media Player now has built-in support for HTML5 audio/video! 
  
Most modern browsers support the MP4 format, so specifying alternative formats is generally no longer 
necessary. MP4 videos should work seamlessly across all current browsers. 
 
Type 
Specifies the type of media player. 
 

• Default 
If this option is selected then the browser will use the default media player as configured in the 
user's preferences. 
 

• HTML5 Audio 
Use this option if you want to use HTML5 audio. 
 

• HTML5 Video 
Use this option if you want to use HTML5 video  

 
Filename 
Specifies the filename or URL of the audio/video to play. 
 
Auto start 
To play the movie automatically when the site visitor opens the page, select Auto Start. 
Note:  Many of today's browsers (for example, Chrome and Safari) block 'auto play' when 'audio' is 
detected.  The same applies to devices such as Android / iPad / iPhone as they do not support 'auto play' 
as it is deemed annoying for visitors, it uses more bandwidth, and it can also affect battery life of the 
device. You can set the audio to 'mute' as this usually allows the browser to play the video due to 'audio' 
not being detected or remove the 'audio' from the video itself.  
 
Use Plyr 
Specifies whether to use the 'plyr' media player (https://plyr.io/) instead of the standard UI. 
 
Loop 
To replay the movie when it ends, select Loop. 
 
Show controls 
If present, controls will be displayed, such as a play button. The actual appearance of the player depends 
on the type of browser! Each browser will render the player differently!!! 
  
Preload media 
If present, the video will be loaded at page load, and ready to run. Ignored if "autoplay" is present. 
 
Mute audio (applies to HTML5 video only). 
Specifies whether the audio should be muted. 
  
Alternative formats (applies to HTML5 video only). 
Previously, not all browsers supported the same audio and video formats, which is why the option to 
specify alternative formats was introduced. However, most modern browsers now support the MP4 
format for video and MP3 for audio, making it generally unnecessary to specify alternative formats. 
  
Poster 
Specifies the filename or URL of an image representing the video.  
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Breadcrumb 

Breadcrumbs are used to enhance the accessibility of a website by indicating the location using a 
navigational hierarchy. You can either manually configure all links for the menu or automatically 
synchronize with Site manager. Also supports FontAwesome icons. 
 

 
 
Symbol 
Use '>>>' for special arrow separator. You can increase the 'padding' to control the sharpness of the 
arrow.  A value of 15 gives pretty good results. 
 
Use this menu for CMS 
Enable this option to use the menu with the CMS tools. Instead of a static menu, the links will be 
dynamically generated based on the CMS database. 
Note that this only works when the page has been published! 
 
Synchronize  
Synchronize the menu with the Site Manager structure, bookmarks on the same page or with other 
menus. See also “Synchronize Navigation” later in this document. 
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Go Menu 

You can use the Go Menu component to easily create a drop-down navigation menu, with each menu 
item corresponding to a single URL or page on your web site. When the user presses the Go button the 
select link will be activated. 
 

 
 
 
Initial Text 
This is the initial text which will be displayed in the dropdown menu. 
 
Button Text 
The text of the button 
 
Do not use button 
Select this checkbox to hide the go button. Is this case a dropdown menu selection will trigger the link. 
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Layer Menu 

Layer Menu is an advanced menu where the drop-down menus are layers. This is great for creating 
advanced mega menus with images, text, form or any other object! The drop-down layer can be 
positioned left, centered or at the right of the buttons. It is also possible to make the layer full width of 
the page. 
 

 
 
 

Notes:  
Main buttons can have links, make the layer size smaller than 48 pixels to remove the layer from the 
item. 
- button modes, set spacing to 0  
- not recommended for smaller screens. 
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Mega Menu 
Mega Menus are drop down menus that contain multiple columns of links. They enable access to all 
links at once, rather than forcing the user to scroll or use sub-menus. One of the unique features of this 
Mega Menu is that you can set different drop-down styles for each button. The drop down can have 
rows, columns, just a simple menu or no menu at all! 
 

 
 
 
Menu Layout 
Specifies how the items in the submenu will be displayed. 
 

• Columns only 
All categories will be displayed in columns (1 row).  

• Rows only 
All categories will be displayed in rows (1 column)  

• 2 columns 
Categories will be displayed in 2 columns.  

• 3 columns 
Categories will be displayed in 3 columns.  

• 4 columns 
Categories will be displayed in 2 columns  

• Simple menu 
Displays a simple drop-down menu  

• Button only 
The button has no sub menu.  

 
Links are organized in categories. To add a new category, click the ‘Add category’ button and specify a 
name. To add a link to a category, first select the category name and then click ‘Add Link’. 
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Pagination 

If you have a web site with lots of pages, you may wish to add the pagination object for easier 
navigation. 
 

 
 
Synchronize  
Synchronize the menu with the Site Manager structure, bookmarks on the same page or with other 
menus. See also “Synchronize Navigation” later in this document. 
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Panel Menu 

A Panel Menu is initially invisible but can slide from the right or left side of the page by clicking the menu 
button. Many modern web sites use this menu type. 
 

 
 
The general menu settings are the same as for other menu types like the navigation bar. 
 
Text 
Specifies the text of the menu button. This field can also be used to configure hamburger animations! By 
using special characters, the button will display a hamburger menu symbol instead of text. When 
clicked, the bars will animation into a close symbol. 
 
12 different animations are available: 
transform: =  
one bar:  _ 
spinner:  @ 
rotate:  * 
90 degrees: | 
arrow left: < 
arrow right: > 
arrow up: ^ 
arrow down: v 
minus:  - 
plus:  + 
times:  x 
 
Icon 
Image that can be displayed on the button. The icon position can be used to control the icon position 
relative to the text. 
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Responsive Menu 

The Responsive menu is a responsive, multi-level menu optimized for desktop computers and mobile 
(touch) devices which uses CSS only (not JavaScript). On desktop computers the menu will display a 
standard drop down menu and on mobile devices it will display a multi-level stacked menu with the 
common ‘hamburger’ icon.  
 

 
 
The menu supports FontAwesome icons to give your website a modern look and feel. 
 
Breakpoint 
Specifies the browser width where the menu will switch from desktop to mobile mode. 
 
Most other styles and menu related properties are the same as in other menus. 
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SiteTree 

 

 
The SiteTree can display an overview of your website (a Site map) so visitors can quickly find what 
they're looking for. 
 

Tip:  
Do not confuse this object with the SiteMap option in the Tools menu, which is purely meant for search 
engines! 

 
The SiteTree will display all pages of your website, except for the pages which you have marked 'Don't 
Synchronize this Page in Navigation Objects.'. 
This object has 3 display styles, each giving a completely different overview of your site: 
 
Alphabetical 
Displays an alphabetical list of all the pages of your website. 
 
Category 
Displays all the pages of your website grouped by category. 
For this style to work correctly, you must first assign one or more categories to a page. You can either do 
this in the Page Properties (meta tags) or in the General Properties of the SiteTree itself. 
 
Treeview 
Displays all the pages of your website in a tree view based on the structure of the site in the Site 
Manager. 
 
In the General Properties of this object, you can quickly update the display name (is the same as the 
menu name property in Page Properties), the page description (Description meta tag) and the 
categories. 
You can assign one or more categories to a page (separated with a comma).  
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Tab Menu 

 

 
The Tab Menu is yet another way to implement your website navigation.  
The biggest difference between the navigation bar and the tab menu (besides its appearance) is that a 
tab menu item has 3 states: 

1. Normal 
Idle state 

2. Hover 
Mouse over or Rollover state 

3. Activate 
The selected item is the current page.  

 
Tab Menu Style 
WYSIWYG Web Builder includes several themes you can choose for the appearance of the tab menu. 
The default theme is text only and does not use any images. The other themes are defined in the 
tabmenu folder (My Documents\WYSIWYG Web Builder\system\tabmenu\) and usually are made of 2 
images. If you like you can modify these themes or create your own themes. 
 
RWD 
The breakpoint value in the Responsive Web Design (RWD) tab specifies when the menu will switch 
from horizontal to vertical mode. 
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Text Menu 

The Text Menu is a text-only version of the Navigation bar. 
Text menus can speed up the navigation through your website, because no images need to be loaded 
first before the user can navigate to another page. 
 

 
 
Target 
Specifies the target window of the links when 'Synchronize with Site Manager' is enabled. 
 
Level 
This value specifies which level of the Site Manager will be used to create the items.  

• First Level  
Creates buttons that will link to the children of the root level. 

• Parent Level  
Creates buttons that will link to all pages in the level above the current page. 

• Current Level  
Creates buttons that will link to the current page and all other pages that share the same 
parent page. 

• Child Level  
Create buttons that will link to the children of the current page. 
 

Spacing 
This setting specifies the space between 2 items. 

 
Link Style 
All links in your webpage by default use the default HTML link colors (link: blue, visited: purple, active: 
red). By defining link styles (CCS) you can adjust the colors and formatting of a link. Once you have 
defined a style you can attach it to the Text Menu by selecting it from the Link Style dropdown list. Click 
the Edit Styles button to add or modify the link style sheet. 
 
Delimiters 
Specify special characters to put before and after the link text. Common characters include {, [  and (. 
 
RWD 
The breakpoint value in the Responsive Web Design (RWD) tab specifies when the menu will switch 
from horizontal to vertical mode if the layout type is set to 'Responsive'. 
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ClipArt 

 

 
ClipArt uses dingbat fonts and converts them to vector shapes. It has all the features of shapes, but it 
allows you to insert any type of shape to your page! 
You can download thousands of free dingbat fonts from the Internet. Search for 'free dingbat fonts' to 
find all large collection of new shapes. After you've downloaded one or more files you can copy them to 
the 'clipart' folder in the Web Builder system folder:  
My Documents\WYSIWYG Web Builder\system\clipart\ 
 
Dingbat fonts have the file extension '.ttf'. There are also many tools available to create your own 
dingbat collections. The filename of the Dingbats font will be displayed as the category name in the 
clipart selection. 
 
For more details about the properties of the ClipArt object see Shapes. 
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Curve 

The Curve tool lets you draw curved lines. A curve can be open or closed. 
 

 
 
To draw a curved line: 

1. Click the Curve Tool on the Toolbox or click Insert -> Drawing -> Curve.  
 

2. Click and release the left mouse button where you want the Curve to start, while dragging the 
mouse press and press/release the mouse button to add points. 
 

3. To end the curve, double click the left mouse button or press the ESC-key.  
 

When the curve is selected, the individual nodes can be changed by dragging them to a new position. 
 
 
 
Description  
This text, usually a short description, appears in place of the object in browser when images are 
unsupported or have been disabled.  
 
Fill Effect (Closed Curve only) 
Specifies the fill effect of the polygon: Solid, Gradient, Texture, Hatch or Transparent. 
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Curved Text 

 

 
With the Curved Text object, you can draw text along a user defined curve. 
 
First you will have to draw a curved line: 

1. Click the Curved Text on the Toolbox or click Insert -> Drawing -> Curved Text.  
 

2. Click and release the left mouse button where you want the Curve to start, while dragging the 
mouse press and press/release the mouse button to add points. 
 

To end the curve, double click the left mouse button or press the ESC-key.  
Then double the Curved Text to edit other properties. 
 
For more information about adding, editing or removing nodes see 'Edit Points' in the Arrange Menu. 
 
All properties of the Curved Text object are the same as the Shape object. 
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Line 

The Line tool of WYSIWYG Web Builder gives you much control over its appearance than the standard 
HTML horizontal line. The Line can be drawn using any angle, color, style and can even have arrows on 
the start or end of the line! 
 
To draw a line: 

1. Click the Line Tool on the Toolbox or click Insert -> Drawing -> Line.  
 

2. Click where you want the line to start and hold the left mouse button down as you draw. To 
end the line, release the mouse button. 

 

 
 
Size 
Specifies the thickness of the line.  
 
Style 
Specifies the style of the line (Solid, Dash, Dot, Dash Dot or Dash Dot Sor).  
 
Arrow Start 
Specifies the arrow type of the start of the line (Arrow, Circle, Square, Diamond, Stealth or Open Arrow). 
 
Arrow End 
Specifies the arrow type of the end of the line. 
 
Arrow Size 
Specify the size of the arrow. 
 
Description 
This text, usually a short description, appears in place of the object in browser when images are 
unsupported or have been disabled. In some browsers it appears as a ToolTip when you move the 
mouse over the image. 
 
Connector Type 
Specifies the connector type. Elbow and Curve connectors are commonly used in flow charts. 

• Line 
Draws a straight line. 

• Elbow 
Draws an elbow line. 

• Curve 
Draws a curved lined. 

 
Connector orientation 
Specifies the connector orientation. Horizontal, Vertical or Auto. 
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Polygon 

The Polygon tool lets you draw polygons with borders and several filling methods. 
 

 
 
To draw a polygon: 

1. Click the Polygon Tool on the Toolbox or click Insert -> Drawing -> Polygon.  
 

2. Click and release the left mouse button where you want the polygon to start, while dragging 
the mouse press and press/release the mouse button to add points.  
 

3. To end and close the polygon, double click the left mouse button or press the ESC-key.  
 

When the polygon is selected, the individual nodes can be changed by dragging them to a new position. 
 
Description  
This text, usually a short description, appears in place of the object in browser when images are 
unsupported or have been disabled.  
 
Fill Effect 
Specifies the fill effect of the polygon: Solid, Gradient, Texture, Hatch or Transparent. 
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Scribble 

The Scribble tool lets you sketch curved lines and shapes in a freeform way. 
 
To draw a freeform line: 

1. Click the Scribble Tool on the Toolbox or click Insert -> Drawing -> Scribble.  
 

2. Click where you want the line to start and hold the left mouse button down as you draw. The 
line will be drawn immediately and follows your mouse movements. Releasing the mouse 
button will draw a straight line from the point where you released the button to the current 
mouse position. 
 

3. To end the line, double click the left mouse button or press the ESC-key.  
 

When the line is selected, the individual nodes can be changed by dragging them to a new position. 
 

 
 
Description  
This text, usually a short description, appears in place of the object in browser when images are 
unsupported or have been disabled.  
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Shape 

The Shape object can be used to 'draw' a shape on your webpage. When you publish a page with 
shapes, Web Builder generates each shape as a .gif file. 
 

 
 
Type: Select the type of shape you want to display on your web page. 

• Rectangle 

• Round Rectangle 

• Ellipse 

• Diamond 

• Hexagon 

• Octagon 

• Arrows 

• Signs 

• Stars 

• Talk Bubbles  

• and many more. 
 

Some shapes have a few variants that you can choose from. 
 
To add a border to the Shape, select 'Enable Border' and specify the border width and color. 
 
You can select from several Fill Effects: 
1. Solid Color 
2. Gradient 
3. Tiled or stretched image. 
4. Transparent 
5. Pattern 
6. Vista Glass 
 
Anti Alias 
Enable this option to improve the quality of graphics. It may slow down the performance of the 
application. 
 
Inner Shadow 
This option will add a bevel effect (inner shadow) to the shape. A Blur value '0' will disable the effect. 
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Output format  
Normally shapes will be published as images, for larger shapes this may have some impact on the 
performance of your website. However modern browsers (FireFox 5, IE9, Safari, Chrome) now have 
built-in support for alternatives formats like <canvas> and <svg>. 
WYSIWYG Web Builder now enables you to convert your shapes into native HTML5 elements! 
  
Select 'Publish as <canvas> to output the shape using HTML5's <canvas> element. Basically, this 
generates a complex set of JavaScript calls to draw the shape in the browser. 
  
Select 'Publish as <svg> to output the shape using HTML5's <svg> element. This will output SVG 
instructions for the browser to draw the shape as a vector-based image. 
 
Select 'Publish as CSS3' to output the shape using CSS3 styling. This will output a standard <div> with 
CSS3 styling (border and background color). Note in this mode only rectangle, ellipse and rounded 
corner shapes are possible, because CSS does not support any other shape types! 
 
Known limitations:  
- This is a new technique and not all WYSIWYG Web Builder shape features are available yet, but we will 
continue to improve the software when browsers will catch up;) 
- Not all gradient effects are supported.  
- Text on shape is not supported.  
- Dotted and dashed border are not supported for <canvas>. 
- Shadow and other images effects are not supported. 

 
 
Add text to a Shape 
A useful feature is the ability to add formatted text to a shape. For example, to create logos or banners. 
Text can be aligned to any edge of the shape. The available space for text within the shape may vary 
depending on the type of shape you've selected. 
 

Note:  
Text will not be visible if the object is transparent! 

 

 
Rotation 
To rotate a shape: 

1. Select the Rotate tool on the Toolbox or click Edit -> Rotate. 
2. Click to select the object, hover over one of its handles until you see the rotate pointer.  
3. Hold the mouse button down and drag in the direction in which you want to rotate the object, 

then release. Use the Shift key for 15° rotation intervals. 
 
Notes: 

• Rotating large shapes can take a long time. 

• Rotating shapes may reduce the display quality of the object. 
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Photo Gallery 

The Photo Gallery is a powerful tool to create amazing galleries. The gallery supports titles, descriptions, 
frames, lightboxes, polaroid mode and much more! Adding a gallery is very easy: just drag & drop the 
Photo Gallery object to the page, then double click it to add images. 
 

 
 
Source 
This option specifies where the images for the gallery are located. 

• Use Local images 
The images will be loaded from the local computer. 
 

• Get images from a folder on the server 
This loads the images form a folder on the server. This uses PHP so the file extension in Page 
Properties should be set to PHP and the page only works online! If the images have description 
meta data, then this will automatically be used for the title.  

 
Thumbnail title 
Enter the text that will be displayed under the thumbnail image. To enable titles, make sure you 
selected the 'Include title' option in the Text Page. 
 
Thumbnail size 
Specifies the size of the thumbnail images. Select 'Variable' to dynamically determine the thumbnail 
size. Select 'Responsive' to make the photo gallery responsive. When this option is selected the gallery 
can have a different number of columns in breakpoints! The images in the gallery will be responsively 
resized based on the available space. This means for example that when the gallery is inside a layout 
grid that it can be full width. 
 
Columns 
The number of images per row. 
 
Horizontal alignment 
Alignment of the thumb images. This option has no effect when the Maintain aspect ratio option is off. 
 
Vertical Alignment 
Alignment of the thumb images. This option has no effect when the Maintain aspect ratio option is off. 
 






